Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just bought a 500GB usb hdd and I saw it has one primary FAT32 partition using all the space... sounds good...
Then I tried some configuration and finally needed to reformat hdd with a single FAT32 primary partition but... surprise, now Windows XP permits this nor some live linux distro: they make me create this kind of partition using maximum 384GB.
Why? Am I stupid? Am I doing a silly mistake or what?
Thanks.

share|improve this question
    
some forums recommend gparted on a livecd (bootable linux usb/cd), apparently Windows 7 will also format 500GB FAT32. –  PP. Apr 28 '11 at 22:53
    
@PP: I've already tried with GParted live, but the result was the same. I will try with Seven and let you know. Thanks –  Marco Apr 28 '11 at 22:59
add comment

1 Answer

up vote 1 down vote accepted

See Microsoft Support Article about FAT32 Limitations with Windows XP. It says that the maximum disk size is approximately 8TB.

The maximum number of clusters is 268 million. The maximum cluster size is 32KB. So you've got to work out how to format using a larger cluster size.

Update: try the FORMAT command with the following flags:

/FS:FAT32
/A:8192

The /FS sets the filesystem type and the /A sets the default allocation unit size.

share|improve this answer
    
curious: I tried using format as you said, but up to 64k it say it's too low, but from 128k it's too high!! So, the only solution is to use exFAT in Seven? Sounds strange... What do you think? –  Marco Apr 29 '11 at 11:40
    
I've accepted your answer not because it was correct, but for your perfect comment on exFAT on Seven. Thanks a lot, you solved my problem anyway :) –  Marco Apr 30 '11 at 16:41
    
@Marco I'm sorry you were not able to solve the problem, I was hoping (though I could not try) a variation of the format command would do what you wanted. –  PP. May 8 '11 at 0:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.