Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use MSYS Git and have the MSYS shell installed. I run Windows XP. All of the sudden basic tasks like runnig ls take many many seconds (>7 seconds) in the Git Bash shell or in the MSYS shell.

Interestingly, even after ls "runs" it takes three seconds for the Bash prompt to return.

When I run ls from Window's native cmd.exe, shell, it seems fine and snappy.

I upgraded MSYS and Git. I did the reboot. Anyone have any ideas why the sudden change?

It seemed to occur after I get perl crash dump. I don't know if the two are related, but here is the contents of perl.exe.crashdump

MSYS-1.0.11 Build:2009-05-12 18:47
Exception: STATUS_ACCESS_VIOLATION at eip=3004DB2F
eax=00000000 ebx=0022FC64 ecx=00000006 edx=00000000 esi=3004DB40 edi=300AB12C
ebp=0022FBF4 esp=0022FBDC program=C:\Program Files\Git\bin\perl.exe
cs=001B ds=0023 es=0023 fs=003B gs=0000 ss=0023
Stack trace:
Frame     Function  Args
0022FBF4  3004DB2F  (0022FC64, 7C800000, FFFFFFFF, 7C90CFFA)
0022FC24  300B5F13  (0022FC64, 00000006, FFFFFFFF, 7C90CFFA)
0022FC94  30063D70  (000003F8, FFFFFFFF, 0022FCD4, 300059AB)
0022FCD4  30005AC4  (00000000, 3009D350, 0022FD24, 677F12F2)
0022FCF4  30005CB3  (00000000, 00000000, 0022FD24, 3009CE5F)
0022FD24  3009CE93  (00000000, 00000001, 0022FD54, 004010C3)
0022FD54  00401150  (00000003, 0A0121A0, 0A010278, 00000000)
0022FF30  3000553F  (00000000, 805592F8, 87A9AAD8, 87A9AA00)
0022FF50  300056D5  (FF676980, FFFFFFFF, 0022FF90, 00401DB8)
0022FF60  30005722  (00000000, 00000000, A3799C6C, 00000000)
0022FF90  00401DB8  (00401068, 00000000, 00000001, 00000006)
0022FFC0  0040103D  (0022F644, 7C8101A3, 7FFD4000, 8054B6ED)
0022FFF0  7C817077  (00401000, 00000000, 78746341, 00000020)
End of stack trace  32921 [main] perl.exe" 1016 winpids::enumNT: error 0xC0000005 reading system process information
share|improve this question

1 Answer 1

Te problem seems to lie with a special command that git runs after every command, called __git_ps1. Removing this command solves the problem. See the answer to:

http://stackoverflow.com/q/5851611/200688

It appears that perl is unrelated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.