Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I have already started Google Chrome, then start it again, the window is not maximized; I have to click to maximize it.

Are there any hidden parameters to set Google Chrome to always start in a maximized window? (not full screen - F11)

share|improve this question
    
@LancelBaynes: What window manager are you using? –  Adam Prax May 14 '11 at 7:13
    
I'm personally curious if there's any way to start it in Full Screen mode, i.e. with F11). =) –  user76871 May 15 '11 at 15:11
    
stable version will be with next release : google.com/support/forum/p/Chrome/… –  NT. May 20 '11 at 8:06

11 Answers 11

up vote 0 down vote accepted

Extending the solution said by Yab as follows:

  1. Rename the first instance to something else e.g. wmctrl -r "New Tab - Google Chrome" -T "test"

  2. Now maximize the second instance as:
    wmctrl -r "New Tab - Google Chrome" -b add,maximized_vert,maximized_horz

These two commands will maximize the second instance of Google Chrome.

If you want, you can put this in a script to call the second instance.

share|improve this answer
    
This solution is overkill. Please mark as correct the below answer with 20+ points. –  Leo Gallucci Jan 17 at 12:11

Google Chrome accepts the command-line parameter --start-maximized, which will force Chrome to start in a maximized state.

Simply modify the shortcut you use to launch Chrome to include this flag, or simply alias chrome to chrome --start-maximized. I've tested this in both Chrome and Chromium under Windows and Linux, and it seems to work just fine.

share|improve this answer
    
Sorry but I tried it under Fedora 14 and it doesn't work :O –  LanceBaynes May 20 '11 at 4:20
    
Did you compile chrome yourself? Perhaps something was left out of the compilation that rendered the command line options missing (though this seems unlikely - I tested under gentoo). If you're using a pre-compiled package, the option should most definitely work. Is any error message returned? –  Fopedush May 21 '11 at 4:27
    
This doesn't work on my box. I'm using xubuntu with google's official deb package. When I try it, it doesn't give any error, but is not maximized. (but then again, I wasn't able to get an error with any parameter, even if I just type gibberish.) –  Yab May 21 '11 at 5:31
    
This works sometimes, but not always. I'm starting to think it is literally impossible to configure Chrome to start in a non-minimized state, as if there is a random decision made internally on startup. –  tbone Mar 19 at 17:01

To start Google Chrome in a maximized window, right click the shortcut, select "Properties" from the context menu.

Then, in the window that pops up, under "Run:" select Maximized from the dropdown menu.

Finally, click OK.

Chrome will now start Maximized

share|improve this answer
2  
I forgot to say that I'm using Fedora 14, but yes, thanks:) –  LanceBaynes Apr 29 '11 at 10:08
    
As with other solutions, only works sometimes (on Windows) –  tbone Mar 19 at 17:01

Sometimes the window state fails to save your last setting due to lack of permissions and therefore keeps opening in the non-maximized mode. You can perform the following to change the owner:group back to yourself for the files:

sudo chown youracct:youracct ~/.config/google-chrome/Local\ State
sudo chown youracct:youracct ~/.config/google-chrome/Default/Preferences
share|improve this answer
    
I checked, I'm the owner of these two files, but thank you! –  LanceBaynes May 20 '11 at 4:21
  1. go to properties on the Chrome short cut.
  2. go to Target, where it has "C:\Users etc..
  3. at the end of 'exe' put a space and then type - google.com (or which ever hopepage you want to set.
  4. click ok. close the browser, then reopen and it should work.
share|improve this answer

In Linux, if you are familiar with scripting, you could use a script to launch google-chrome, in which you'd invoke a program like wmctrl or xdotool (should be in your package manager) to maximize the new window.

share|improve this answer
    
That could be a last chance. –  LanceBaynes May 20 '11 at 4:22

By default, Chrome chooses to apply its own window decorations rather than the window manager ones, and accept responsibility for implementing various pieces of logic. It tends to work well enough in Gnome and KDE environments and less well the further you stray from those.

If you right-click in the title-bar area, there's an option to turn on using the system window manager controls. If you do that, Chrome might inter-operate better with your regular window manager and more reliably implement full-screen. Or, it might get worse — it's unfortunately one of those "suck it and see" changes, the success of which varies wildly across both window manager and version of Chrome. I've had it make some things better and some things worse, when I was using xfwm4, with a later release of Chrome working better with its own window decorations than with the system ones, for my setup.

share|improve this answer

wmctrl or --start-maximize switch will work if you use a windows manager. X session itself is unaware of window's maximization.

In case you want to save some resources using no windows manager, you could employ xdotool:

xdotool search --onlyvisible --class browser windowsize 100% 100%
share|improve this answer

This worked for me.

When maximized, in the upper right hand corner click on the Double squares (between the X and the -). Change the size a bit. Maximize. Voila, Chrome will open maximimized.

It seems that Chrome will only remember the size and position after some sort of change.

Good Luck.

share|improve this answer
    
This isn't an appropriate solution. OP's looking for a flag or parameter to set to guarantee it always starts maximized. –  DanteTheEgregore Oct 6 '13 at 14:12

On Xfce 4.10 (Xubuntu 13.10) you have to put the --start-maximized parameter before the %U parameter for it to work.

share|improve this answer
    
Your reply is not complete. You are probably extending another reply so please add the important information into you reply. Where should you put --start-maximize before %U? which setting of Xfce is it? –  pabouk Oct 31 '13 at 9:57

I think I may have your solution. I was having the same problem and this is how I fixed it. The problem I had was not with Chrome but with Windows 7. The browser was not opening full due to a windows "padding" setting. (it reminded me of a CSS issue)

Try this... I use a tweaker called "ultimate windows tweaker" found here link for examples and DL

But you can change your padding here manually. Instructions

How ever you change it is up to you.

Now make sure you change the padding to "0"

Once that is done you will need to re-make your apps.

Now Try going to GMAIL(or whatever), then tools, create application shortcut, apply to desktop. When you are done there it is the same as before... properties>RUN>Maximized

Good luck I hope this clears up the issue. -Mike

share|improve this answer
1  
Hello michael, this may work on a Windows 7 systems. But this question was for a fedora (linux) system. I checked your links and I see no way how this can be used on linux. –  nixda Jan 6 '13 at 17:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.