Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am geeting this error whenever i am using the below command in ubuntu: ssh localhost

it shows the error unable to connect to local host at port 22:connection refused

Please help me with this

share|improve this question
add comment

migrated from stackoverflow.com Apr 29 '11 at 9:26

This question came from our site for professional and enthusiast programmers.

4 Answers

Do an ifconfig and check that Local Loopback is enabled.

share|improve this answer
add comment

It probably means that you don't have sshd running, or it could be a misconfigured firewall (yes, you can firewall off localhost).

share|improve this answer
    
how can i turn on sshd ..plz help i am very new to linux environment?? –  Adi Apr 28 '11 at 3:52
add comment

Maybe you don't have start server sshd.

ps aux | grep sshd to check it

share|improve this answer
    
how to turn on sshd ? plz help on this –  Adi Apr 28 '11 at 3:59
add comment

You need a ssh server. Read the community documentation on it for Ubuntu (it's short).

Install it via Terminal:

sudo apt-get install openssh-server

And try connecting:

ssh localhost
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.