Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am not able to telnet in to localhost .

[root@localhost ~]# telnet localhost
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Red Hat Enterprise Linux Server release 5.5 (Tikanga)
Kernel 2.6.18-194.el5PAE on an i686
login: -h for super-user only.
Connection closed by foreign host.


[root@localhost ~]# su - admin
[admin@localhost ~]$ telnet localhost
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Red Hat Enterprise Linux Server release 5.5 (Tikanga)
Kernel 2.6.18-194.el5PAE on an i686
login: -h for super-user only.
Connection closed by foreign host.
[admin@localhost ~]$

What might be the solution ?

share|improve this question

migrated from stackoverflow.com Apr 29 '11 at 11:01

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers

In year 2011, the right solution is do not use telnet. Switch to SSH instead: enable sshd, then run ssh 127.0.0.1.


The telnetd daemon on your system is misconfigured: it's supposed to be started as root.

Edit your inetd configuration file. For xinetd, add user = root to the telnet service definition; with classic inetd, the user is the 5th field in /etc/inetd.conf. When done, pkill -HUP -f inetd.

share|improve this answer
add comment

The solution is to add the following line to xinetd.conf

user=root

and then restart xinetd service.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.