Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Accessing wireless network usually works fine on my Ubuntu 10.10 on Lenovo T400. But sometimes,

  1. Lost wireless connection after the OS having been on almost a week:

    When it happens like today, I cannot connect to a wireless network, although Network Manager can detect and show all available wireless networks. It is also strange that WICD cannot detect any available wireless networks either.

  2. Lost wireless connection every few minutes:

    When this happens, the wireless network connection became lost after a few minutes. After manually trying to reconnect, it was able to connect again, although it got lost again after another few minutes.

My system has been up for almost a week, and there have been various programs running including Firefox, Google Chrome, and HTTrack. Not sure these can be factors of the problem.

I was wondering why the problem happens and what I can try to solve the problem?

Thanks and regards!

share|improve this question
Running a linux machine for a week without reboot is nothing :) its like saying you had Windows running for 5 minutes. People go years without rebooting their linux box so you can rule that out. Yes I meant to type years. Did you have to reboot because of an update? – Arctor May 7 '11 at 18:41
This is basic wireless network troubleshooting. You'll need to tell us more details: Has it ever worked? When did it stop working? What, if anything, changed immediately before it stopped working? How far are you from the AP? Are there items that could be causing interference (cordless phones, wireless speakers, microwave ovens)? Have you tried using different channels? Is your building made of brick, or does it have metal struts? Is your computer in a basement or attic? Have you tried swapping out the wireless adapter to see if it's a hardware problem? – goblinbox May 8 '11 at 22:14
@goblinbox: Yes, it used to work fine. Stop working several days, or a few hours after start. I open applications such as Firefox, documents, among others. Whenever the problem occurs, if I immediately restart, it will be fine again. I don't think other factors you mentioned are the reason. – Tim May 13 '11 at 4:40
Could be a failing wireless adapter. Or it could still be interference. Do you have another adapter you can try? – goblinbox May 22 '11 at 22:24

You must log in to answer this question.

Browse other questions tagged .