Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Uh. I looked at the properties on windows, it says that its formatted as RAW, and 0 bytes. When I try to format, no matter what filesystem I use, I can only format to 1.92 GB. I have tried on 2 windows 7 machines and an XP, I'll try Ubuntu or Fedora when I get home if that might work.

share|improve this question

migrated from Apr 29 '11 at 19:39

This question came from our site for professional and enthusiast programmers.

Have you ever actually had this device formatted to 4gb, or is it new? – Fopedush Apr 29 '11 at 19:57
Have you tried partitioning the drive? – CarlF Apr 29 '11 at 19:57
Is it possible that you bought a cheap knock-off that is really only 2GB or had a hardware failure? – Justin Pearce Apr 29 '11 at 20:57
Mind telling us the brand name of the drive? (Might find interesting:…) – LawrenceC Apr 30 '11 at 15:20

2 Answers 2

Hard to tell without more information, but the most likely answer is that your drive really is a 2GB drive. Some unscrupulous people sell devices with a faked capacity.

The drives are doctored to report a higher capacity than they really have. Sometimes this is accomplished by manipulating the filesystem structures on the device, then reformatting such a device will show the true capacity, because it corrects the doctored filesystem structures.

See e.g. this link for some explanations: BurnInTest FAQ - Testing for fake counterfeit USB drive capacity .

share|improve this answer

Are you using a 32-bit system?

share|improve this answer
That is only applicable to memory, as 32-bit memory addresses run out. The OP is referring to a USB pen drive, which serves as a removable storage device. – Paul Lammertsma Apr 30 '11 at 14:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.