Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I open Skype, it crashes when I log in. I've re-installed, restarted, and tried deleting the directory C:\Users\user\AppData\Roaming\Skype\MySkypeUsername, all to no avail. It will start up and ask me to sign up/in, but when I click sign in crashes immediately. It's been working fine up 'til now, could an update have broken it?

share|improve this question
    
fredley, you may want to enable logging for skype so you can post of a log of the crash, the following link contains instructions on how to enable logging in Windows: developer.skype.com/SkypeGarage/LogFile –  William Tate Apr 29 '11 at 20:22

2 Answers 2

Same happened to me today after an update. I fixed it by DISABLING the "Vista compatibility mode" option, which I had set.

Instructions: right-click over program icon, Properties->Compatibility UNCHECK the checkbox "Run this program in compatibility mode for..."

Worked for me.

Note: I had set previously the Vista compat mode to get the old behaviour of puting the skype icon in the alert area (instead of the taskbar) when minimized. Bot this can now be done in the Options->Advanced->Keep Skype in taskbar... (uncheck)

BTW: I had this crash (first in my Skype) minutes after knowing about MS buying Skype... but it seems it was just a coincidence :-)

Moved from closed question.

share|improve this answer
    
Nope, doesn't work. Skype have sent my crash log to the developers, but I've given up hope of anyone getting back to me on this. –  fredley May 12 '11 at 19:57
    
This didn't work for me either. Skype just suddenly started crashing and even a resinstall didn't help. –  user8929 May 26 '11 at 12:36

Try this more recent foobar fix.

Windows

  1. If the Skype icon is displayed in the system tray at the bottom right of the screen, right-click it and select Quit.

  2. Click Start, type "run" and press Enter. (On Windows XP: Click Start and then Run.)

  3. Type "%appdata%\skype" and click OK.

  4. Locate and delete the file shared.xml. The file may be displayed as shared if file extensions are not displayed by default on your computer.

  5. Restart Skype.

If you cannot find this file:

  1. Click Start, type "run" and press Enter. (On Windows XP: Click Start and then Run.)

  2. Type "control folders" and click OK.

  3. In the View tab, ensure that Show hidden files and folders is enabled.

  4. Repeat the instructions from the beginning.

share|improve this answer
    
Tried that, no luck! –  fredley May 26 '11 at 20:55
    
@fredley: A pity, it worked for me this morning. –  Peter K. May 27 '11 at 0:12

protected by random May 26 '11 at 20:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.