Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A couple of months ago I bought a D-Link DIR-652 router. It was working fine until recently but a few days ago I started having problems with the wireless network.

After resetting the router and reconfiguring the wireless network it worked again for several days - but now it's acting up again (I'm simply unable to find it and/or connect to it).

Any ideas what could be wrong?

share|improve this question

closed as not a real question by techie007, Hennes, TFM, 8088, Synetech Nov 19 '12 at 1:28

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

3 Answers

up vote 0 down vote accepted

That sounds like an issue with your router, but it could be the computer you're connecting with. How many computers have you tried to connect with? If only one, could you test with another system? Have you been able to connect to other wireless networks with your test machine(s)? Again, we just want to eliminate the client as the problem before turning to the router.

Next, when you can't see the wireless network, try a wifi enumeration tool like NetStumbler. It won't debug connection problems, but it will let you verify if the network is being seen at all.

Finally, update / reinstall the router firmware via the admin panel. This probably won't help but is worth a shot.

If none of these work it sounds like a physical defect, possibly due to electrical damage from a storm.

share|improve this answer
    
I have multiple computers in my house, as well as a mobile phone - none of them could connect, it's a router issue. I have tried connecting directly to the network without "searching for it", didn't work. Plus I tried the update thing but I have the newest version. My W-lan network did work after I reset it, but this problem reoccurred after the last reset 2 days ago. –  Asaf Apr 30 '11 at 15:54
    
@Asaf: In that case I would try to return that router on warranty or buy a new one. –  BigChief Apr 30 '11 at 16:14
    
I'm really not sure why or how but after completely removing the network-manager and (of course) restarting the modem the problem seems to fix itself (my ISP suggests that I made have had problems with my specific cable outlet in the last apartment) –  Asaf Nov 24 '11 at 5:52
add comment

I had the same problem when several computers and my smartphone (HTC Desire S) were connected. Since disconnecting my smartphone, I have no more problems.

share|improve this answer
add comment

I have exactly the same problem. After a few days my portable computer is not able to connect and when trying to connect again the portable can se the network but it cant connect to it.

I even reconfigured the portable but same problem.

Only thing that seems to help temporally when this occurs is to turn the router off and switch on again.

share|improve this answer
    
Interestingly enough, that's exactly what I did. I tried resetting it, unplugging it, but as soon as I found that there's an on-off switch it worked like a charm, perhaps something's not 100% right with the switch? –  Asaf May 12 '11 at 7:17
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.