Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There have been a lot of questions like this, however mine differs, so don't lock this one as a duplicate just yet.

Others have the problem that they only see categories with missing icons. I'm not seeing anything. It doesn't say "No items match your search" either. It worked before, even this morning. I can't say what I did that broke it, though.

Windows 7 troubleshooting couldn't find the problem, I restarted the Windows Search service, and I rebuilt the search index, but none of that fixed my problem. The problem has appeared before on a different PC also running Windows 7, but I can't recall what caused it, nor what fixed it.

I can verify search working in Windows Explorer, so it isn't search itself that's broken.

Any help is appreciated, as I use this feature quite often.

(Late) edit: the issue seems to have fixed itself after a reboot.

share|improve this question
You might consider explaining what exactly does not work (or happens) when you search from the start menu, maybe add some screenshots also. – Moab Apr 30 '11 at 14:28
As I said, searching in the start menu didn't yield any results, nor did it display "No items match your search" as it usually does. But rebooting fixed it. – horsedrowner May 3 '11 at 6:01

I face this problem once every few months. Logging on-off or rebooting is just not an option for me!

I finally found a drastic solution that works for me:

  1. Open Task Manager, go to the Processes tab, find the Explorer.exe process and click End Process. There might more than one Explorer.exe process, it is pretty harmless to kill them. You know you have killed the right one when the taskbar disappears.

  2. In Task Manager, choose New Task and type in explorer. This will bring back a fresh instance of Explorer.

The Start menu search must be working fine now. Hope it works for you and everyone who faces this vexing problem :-)

share|improve this answer
+1 very helpful – Xaqron May 21 '12 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .