Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way I can disable subpixel work for a specific document? I'd like to be able to move an element on a full pixel grid instead of subpixels, preventing stuff to be placed at 128,23 Y-axis for example.

Same applies to sizes, can I make it so it can only have full pixels for width and height?


share|improve this question

I am pretty sure you can not work with anything less than a full pixel in Photoshop if you are talking about the axis settings those get rounded up or down and the object is shifted accordingly. If your object has feathering this will be affected by the .23 but it will still use a full pixel not a partial one.

I don't know where you would be seeing partial pixel sizes for the document size though...


The top is with no pixel snap setting and the bottom is with a pixel snap setting. Without it the partial pixel gets feathered.

share|improve this answer
I think he must be referring to moving vector objects or paths. – paradroid Apr 30 '11 at 14:43
@paradroid That's what I meant. Not the document size, but rather the position of a vector object in it. – Juan Cortés May 1 '11 at 16:01
It is the same for vector images it creates a feather in the neighboring pixel if you use a partial pixel the color varies based on how much it is set to. You can set the vector shapes to Snap to Pixels under the menu next to them on the vector shapes toolbar. This will help but you could still manually set it to feather. – Arctor May 1 '11 at 16:52

I found out that I could create a 1px grid and enable the snap to grid feature, will more or less fix my problem. Note that if the object you are resizing or moving is already in a subpixel size it will stay that way.

And sometimes when you move it, it will snap to a .99 instead a .00 Anyway, good enough for me.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .