Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using this registry edit for a few months now in windows XP to swap my control and caps lock keys:

http://vim.wikia.com/wiki/Swap_caps-lock_and_control_keys_using_MS_Windows_Registry

today I login and the control (remapped to capslock) does nothing. The capslock (remapped to control) still works. I have tried logging out and in again and removing and applying the registry change, but nothing seems to work. Was there a recent update that breaks this? How would one go about debugging what is going wrong, or better yet, fix this issue?

share|improve this question

migrated from serverfault.com Aug 22 '09 at 12:45

This question came from our site for professional system and network administrators.

add comment

3 Answers 3

up vote 2 down vote accepted

From your link:

"WARNING: Editing your Windows registry may cause unintended side effects that render your system inoperable. Although this tip has worked in the past for some people, there is no guarantee that it will work for you. Use with caution, and at your own risk."

As a Windows admin, that is what I would tell you if you came to me with this issue. You want to play with the registry following guidelines from a UNIX editor website, go ahead, but if it breaks something, it is going right back to the way it was.

After the wrist-slapping was out of the way, I would recommend a solution anyway (because I am nice) that doesn't involve manually editing the fundamentals of Windows operation. This is also from your link:

"As an alternative to changing the registry, there are various utilities that can remap keys. Many of these can be run by a non-administrator, and can apply mappings only when wanted (for example, when running Vim). They do not require log off/on or reboot to apply changes."

Come to think of it, maybe you could get a better response if you ask this question on http://stackoverflow.com/ instead...Sysadmins can be a little sarcastic and testy about stuff like this :)

share|improve this answer
add comment

Why don't you give AutoHotkey a test run. Might be the solution to your problem.

share|improve this answer
add comment

It looks like you have two mappings changed. Have you tried removing the capslock -> control and only have thing control -> capslock active? That would be my first step. Isolate and conquer!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.