Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just upgraded to 11.04 on my VirtualBox VM, and after I start it, it begins to load, but it stops at the line * Checking battery state... [ OK ]

I have tried the recovery mode, but to no avail. I can access the boot commands and the command line, but I have no idea what to do from either.

Before the above line, there is a highlighted line
* PulseAudio configured for per-user sessions
saned disabled; edit /etc/default/saned

share|improve this question
    
Fire up a liveCD in VirtualBox. Mount the "/" partition of your guest and check "/var/log" for messages. –  Shiki Apr 30 '11 at 20:53

1 Answer 1

up vote 9 down vote accepted

I was having the same problem, and I found a solution here in hnyman's post:

I solved the problem by getting into the console mode (Ctrl-Alt-F1) and logging into Ubuntu from that console, then I manually created a mount point for the cdrom and mounted the Guest Additions cdrom, and finally did run the Guest additions script. That solved the problem.

sudo mkdir /media/cdrom
sudo mount /dev/cdrom /media/cdrom/
sudo /media/cdrom/VBoxLinuxAdditions.run

So, it might be advisable to uninstall Guest Additions before the upgrade from 10.10 to 11.04, as the old version might prevent the upgraded system to boot properly into desktop.

Ps. After enabling the 3D accleration in VirtualBox guest system settings, the Unity booted ok, but I decided to stay with the old classic desktop for the time being.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.