Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded Ubuntu to 11.04, but when it rebooted, I saw some command-line stuff, but no GUI. So I downloaded the .iso, and tried to boot from that. Exactly the same thing happened. The GUI is there - I see it when I power off the machine - but it appears to be behind the cli interface.

Is there some keystroke combination that will bring it forward?

share|improve this question

3 Answers 3

Try pressing Ctrl-Alt-F7, then try Ctrl-Alt-F8 if that doesn't work.

share|improve this answer
    
Ctrl-Alt-F7 didn't do anything, Ctrl-Alt-F8 cleared the screen, but that was all. –  David Coldrick May 1 '11 at 2:14
    
OK, tried a few more key combos, found a login prompt with one of them. Logged in, then did a sudo service gdm restart, which appeared to work, giving me a process id. How do I now access the gui (scuse noobness, been a while since I descended to this depth in Linux) –  David Coldrick May 2 '11 at 21:51
    
@David: Return by pressing Ctrl-Alt-F7. –  Hello71 May 2 '11 at 23:37
    
So the ubuntu system is up and running - I can access shares on it from my LAN - but it's simply the GUI that doesn't function. I also am unable to ssh to the box from within the LAN. Is there any log I should be looking at to diagnose the problem(s)? –  David Coldrick May 4 '11 at 1:28

You can try using:

startx

or

service gdm restart
share|improve this answer
    
Neither of those had any effect, unfortunately –  David Coldrick May 1 '11 at 2:13

Which graphics card is being used? I had a similar problem with a laptop using an intel 830m graphics chip. The video card wasn't being detected by ubuntu and it only booted into text mode. Try this: at bootup, hit F6 to enter the grub command line. Find the partition you will boot. Append this text: "vga=771" to load support for older, non-detectable(?) video cards. This change is only in effect at boot time. If it does effect things positively, you'll need to either permanantly edit the grub config, or use that option during the original install.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.