Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows Server 2008 R2 running on a VirtualBox vm inside Mac OS X. I put it in "bridged mode" in hopes that it would receive an IP address through DHCP and become visible as an "attached device" to which I could forward HTTP traffic on port 80.

Indeed it has received a valid 192.168.x.x address and has the router's IP as a default gateway. But it does not show up at an "attached device" as do all other devices getting IP addresses from the router.

Am I doing something wrong here, or is this to be expected? Am I on the right track?

Thanks.

EDIT:

The router is a NetGear N150 Wireless Router, and I'm accessing it through the browser-based NetGear Smart Wizard.

share|improve this question
    
I would have guessed that configuring the guest to use bridged networking would have done the trick. Why do you want it to show up on the router - maybe there is another way to get the information you desire? –  Goyuix May 1 '11 at 1:54
add comment

1 Answer

up vote 0 down vote accepted

The phrasing of "attached devices" and the description in the manual makes me think this list is a list of devices discovered with UPnP.

If UPnP is enabled on the router (it appears to be by default in the manual) try enabling UPnP in the Windows Server 2008 R2 VM. Go Start --> Run --> services.msc. Set the services SSDP Discovery and UPnP Device Host to Automatic start, and start each service (note that UPnP won't start without SSDP already running). You may need to specify a firewall exception for these services. SSDP uses port 1900, and I believe the Device Host uses the same.

SSDP Discovery should allow the VM to be discovered. UPnP Device Host allows more functionality. UPnP and SSDP are disabled by default on Windows Server due to the potential security issues with a system automatically searching for and communicating with arbitrary devices on a network.

share|improve this answer
    
I pushed a little further and realized that the VM could talk to the host and the router, so I went ahead and forwarded the HTTP traffic to the VM and everything worked. Guess the VM didn't have to show up on the "attached devices" list for this to work. Thanks for this input and feedback though! –  user72923 May 1 '11 at 3:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.