Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Edit - this is no longer an issue due to a series of driver updates.

  • Sometime in August/September 2011 (I think, maybe even earlier) an NVidia driver update made it possible to run WQXGA resolution in discrete mode without any arcane and convoluted steps as outlined below.
  • The lenovo update on 7th November 2011 finally allowed me to run WQXGA in optimus mode. Hooray!

Original post below

I have a Thinkpad T520 with NVS4200m and Intel HD graphics, part of the new(ish) sandy-bridge optimus line. I am having some real pain getting it to output WQXGA (2560x1600) to 30" monitors. My experience have been thus:

  • In hybrid/optimus mode, WQXGA does not work at all. Period. The top resolutions it offers are:
    • 1920x1200 (16:10)
    • 2048x1536 (4:3)
  • In discrete mode (pure discrete, set in the bios), WQXGA works intermittently:
    • With a DELL U3011, connected via a displayport cable, I have to reboot with the cable unplugged, turning the monitor off and on again (it seems like some monitors are remembering negotiation information with the device? I'm not sure, but this really does seem to make a difference). If I unplug and re-plug the cable, or send the laptop to sleep and then wake it up, then the WQXGA mode disappears.
    • With the DELL U3011 and another dell (2010wfp? - not sure), connected via an active DisplayPort to DVI-D Dual Link Adapter (the active type, that require usb power), WQXGA also works; it involves the same sort of unplug, reboot, prey behaviour as above.
    • With a Dell 3007WFP this does not work at all.

Hotplug functionality also seems completely spastic. Sometimes after connecting the external monitor I simply cannot enable it until I reboot (NVidia settings will silently fail, attemping to enable the external and click apply in windows resolution settings shows a messagebox saying "The settings could not be saved")

This is pretty disappointing to me. Is there a way I can force the WQXGA display mode?

I've tried to create a custom resolution but it says it is not supported - I haven't tweaked the timing issues because I don't understand them and frankly if I wanted to I would be installing linux.

share|improve this question

1 Answer 1

No definitive answer but here are some tips:

  • Don't use hybrid/integrated graphics. Use discrete (set in bios)
  • Always cold boot the laptop WITHOUT anything plugged into the DisplayPort. No, really.

For a displayport monitor, assuming everything is unplugged and off:

  • Connect DisplayPort cable to the monitor
  • Turn off monitor
  • Boot laptop
  • Connect DisplayPort cable to laptop
  • Turn on monitor

For a DL-DVI monitor with an active DP->DL-DVI adapter:

  • Connect DL-DVI cable to the monitor
  • Connect DL-DVI cable to the adapter
  • Turn off monitor
  • Boot laptop
  • Connect DisplayPort cable of adapter to laptop
  • Connect USB cable of adapter to laptop
  • Turn on monitor
  • Sometimes windows will think the external screen is on, but the external monitor remains blank.
  • Bring up the screen resolution dialog*
  • Set resolution of external monitor to a lower res (I use WUXGA), click apply.
  • If the external display enables, should be able to set it back to WQXGA and hopefully it will work
  • If not, set the resolution to an even lower res and repeat.

Computers, what fun.

*(right click on desktop, select resolution (W7) or properties (XP), press alt-space, press m, press an arrow key (cursor should now disappear). Move cursor around until screen resolution dialog returns to your visible screen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.