Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I try to go to GitHub through Google Chrome 11 I get the following error message:

Chrome

GitHub works perfectly fine in Firefox 4:

enter image description here

This has been going on for a few weeks. This is a fairly new install of Windows (I don't even remember if I've successfully got on to GitHub on this installation with Chrome in the past). I don't even use GitHub for hosting my own code personally, but this has proven annoying in that I can't even access other people's projects through Chrome!

Does anybody know what is going on here?

An interesting side note: The Sight extension for Chrome doesn't work either! It worked on my old installation of Windows but not on this one. Is my Chrome installation just screwy? I've tried disabling certain other extensions but nothing seems to change.

share|improve this question
1  
Are you sure you aren't connecting through a proxy? Interestingly, somebody had the same problem for GitHub but it has resolved itself. –  slhck May 1 '11 at 9:23
    
Yea, I'm at home and I don't have any proxy stuff set up. –  KPthunder May 1 '11 at 14:30
add comment

5 Answers 5

up vote 2 down vote accepted

Ok. So here are some random things I did (simultaneously for some stupid reason so I'm not sure which thing worked) and now the problem is solved.

  1. Opened up Chrome Extensions Management page
  2. Opened up Fiddler (which hadn't been opened in weeks, and I have restarted Chrome many times without Fiddler open).
  3. In Chrome under Developer Mode I hit "update extensions now."
  4. With Fiddler open, now GitHub works.
  5. And now for the kicker. With Fiddler closed GitHub works again. I am sure Fiddler is not running right now and I have restarted Chrome to verify. It's working. Why would this only affect GitHub?
share|improve this answer
add comment

I don't have any issue accessing and login to GitHub with the latest Chrome 11.0.696.60.

Maybe you have an extension that somehow change the user agent?
Or the http header?

share|improve this answer
    
The only browser I have user agent stuff installed in is Firefox. –  KPthunder May 1 '11 at 14:33
    
@KPthunder: ok, some weird interaction with one of your extension, then? I have upvoted your answer. –  VonC May 1 '11 at 17:17
add comment

Today I had the same problem. I am using a proxy server, and it looks like chrome wasn't able to verify the certificate via the proxy server. Because after getting a direct internet connection, it was working again. Now it keeps working even if I use the proxy again.

share|improve this answer
add comment

I had this problem today, too, it worked in Firefox, failed in Chrome (21.0.1180).

Simply clearing the Chrome browsing cache fixed it.

Don't know why it broke in the first place, perhaps it's something related to my company VPN?

share|improve this answer
add comment

This happened me because of AVG Safe Search Chrome extension, then I disabled this extension in chrome extensions and GitHub appeared as normal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.