Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Now that I am using XMonad I find that my USB devices no longer automount when I plug them into my computer. How do I get them to automount again just like they did when I was using gnome?

share|improve this question
add comment

4 Answers 4

I'd recommend one of the udisks-based solutions. uam seems to do the job without too much configuration. udisks-glue is also decent for scripting.

This is just simple tool for mounting pendrives and alikes when inserted -- something like ivman or functionality integrated in KDE/GNOME.

udiskie is a simple daemon that uses udisks to automatically mount removable storage devices.

share|improve this answer
    
Your option is a good one but I marked mine as the answer because it was simpler. (It was a one liner) Yours is probably better memory wise though, probably a little less top heavy. I still gave you an upvote. –  Robert Massaioli May 4 '11 at 23:07
add comment
up vote 4 down vote accepted

The way that I have solved that problem is to use nautilus running the the background to continue to manage that for me. You can do that like so:

nautilus --no-desktop -n &

If you happen to start XMonad using a custom .xsession file then that would be the perfect place to put that line. Make sure you put it before the 'exec xmonad' command.

share|improve this answer
add comment

On Arch Linux ldm works quite well with plain XMonad.

Disks will automatically mount to /media. Disks may be unmounted with sudo pumount or sudo umount.

References:

share|improve this answer
    
I could not get the nautilus option mentioned on this page to work. –  nwhsvc Sep 4 '12 at 20:05
add comment

I think you are better off with udisks. It comes installed by default (at least on Ubuntu) and handles the standard mounting and unmounting like a charm. You can read all about it here - https://help.ubuntu.com/community/AutomaticallyMountPartitions

Btw as the documentation says, udisks is not gnome specific.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.