Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently running Windows 7 on my main machine and before today has a secondary machine running Ubuntu.

I finally decided to install XP on my second machine as I thought it may be more useful than having Ubuntu for me.

My Ubuntu setup before worked perfectly - I have an ethernet cable running from my main machine (that gets internet via WiFi) into my secondary machine and Ubuntu recognised this and gave me internet access!

Unfortunately this has not happened with XP. XP doesn't seem to do anything no matter how many times I plug and unplug the cable. I've had a little look into connection settings, but I can't seem to get anywhere.

IP Settings:

  • Main PC: 192.168.0.103, 255.255.255.0.1
  • XP PC: 192.168.137.207, 255.255.255.0, Gateway: 192.168.137.1
share|improve this question
    
Please be a bit more specific about your settings, plugging/unplugging the cable won't help if there's something wrong in your configuration. Did you wipe your Ubuntu installation? Maybe you had some specific settings there. I assume you didn't change anything on the Windows 7 machine, did you? –  slhck May 1 '11 at 10:55
    
I wiped my partition (just as I did before I installed Ubuntu and Ubuntu worked fine). I've now re-installed the Broadcom drivers for my device and it still doesn't work. (And no - I didn't change the Windows 7 machine at all) –  anon May 1 '11 at 11:01
    
Shouldn't be the drivers causing this issue. By being specific about your settings I meant adding your actual connection settings to the question you posted: For example, have you manually bridged your WiFi and Ethernet connections on the Win 7 machine or did you use Internet Connection Sharing? Which IP Addresses do the machines have? etc. –  slhck May 1 '11 at 11:21
    
I didn't do anything. I just plugged it in and expected it to work (as it did with Ubuntu). Is there anything I should be doing? –  anon May 1 '11 at 11:26
    
Yes, helping us help you by telling us about your network settings :) I quote you on this one: "Try and be more specific if at all possible in all questions you ask online as it's difficult to solve problems such as this without specifics". It could be the simple problem of a wrong IP address configuration in your XP machine. –  slhck May 1 '11 at 11:33

1 Answer 1

up vote 2 down vote accepted

Now, from seeing your IP settings the problem is obvious: In order for the two machines to "see" each other, their ethernet connections have to be in the same IP subnet.

Your Win 7 machine has two network ports, the WiFi and the ethernet port. You need to find out the ethernet address of the Windows 7 machine.

To sum it up, change your Windows XP machine's IP addresses to:

  • IP: 192.168.137.123 (just as an example)
  • Gateway: The ethernet IP Address of your Win 7 machine
share|improve this answer
    
I just did this and all it did was remove the "Wireless Network Connection on JOE-PC" option in my "network connections" (It didn't work :( ) –  joesavage May 1 '11 at 12:50
    
I understand what's happening. I think you didn't post the right IP address of your Windows 7 machine. It should have two network connections (namely the WiFi and the ethernet), but we need the one of the ethernet (i.e. the thing that connects both PCs). –  slhck May 1 '11 at 12:56
    
Ah ok. Well my Windows 7 IP of the "Local Area Connection" is as follows (you were right - I previously used the Wifi): 192.168.137.1, 255.255.255.0 and no default gateway. –  joesavage May 1 '11 at 13:18
    
Ok then your old options were good, I guess. Let me think. Can you run ping 192.168.137.1 from your XP machine (but reset the IP settings like they were before, so that both are in the 137. subnet)? –  slhck May 1 '11 at 13:37
    
Request timed out all 4 times... Any other ideas? –  joesavage May 1 '11 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.