Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok, this one has me scratching my head - and being a n00b isn't helping.

In short, I had a script which I had perfected to covert MKV video to MP4.

However, my Ubuntu 10.10 box bit the dust and installed 11.04.

However, my script is now having problems with the following line:

ffmpeg -i "${title}".ac3 -acodec libfaac -ab 576k "${title}".aac

When it reaches the relevant stage in the script, it returns the error:

Unknown encoder 'libfaac'

I have tried swapping libfaac for aac, which seems to be installed/recognised by ffmpeg - however that codec is just way too slow.

I have no idea how to either;

  1. get libfaac back on my Ubuntu 11.04 install, or
  2. find a better codec than AAC to convert the audio.

Any help to point me in the right direction is greatly appreciated.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

try this: go to system/Administration/synaptic and type libfaac and install it.

if did not work try to install the FULL-FFMPEG from here. The ffmpeg package which comes with Ubuntu is incomplete.

http://ubuntuforums.org/showthread.php?t=786095

share|improve this answer
    
Genius. Thank you for pointing me in the direction of that thread, exactly what I was looking for and solved the problem perfectly. –  thewinchester May 2 '11 at 14:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.