Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know this probably sounds like a silly question, and it sort of is. But just bear with me for a moment.

My girlfriend recently purchased an apartment in Downtown Budapest, and it came with a cable internet connection from Digikabel.hu.

When she's trying to connect to her gmail, hotmail, and most other sites that require that you POST data to the server, the internet connection slows to a crawl. When trying to login to her GMail account, she simply gets a timeout. Hotmail works after a while (+- 5 minutes to login).

She has reported that some other sites are extremely slow loading also. Google.hu works perfectly (very fast), the same counts for google.no. When she's accessing google.com or facebook.com, the wait is also up to five minutes. GTalk and MSN Messenger works halfway – she can receive messages but no-one else receives the messages she sends out. Skype works, though..

She's tried with three different computers (2*MacBook Pro, 1 MacBook), in both Windows 7 and OS X Leopard, so it's not a software problem from her side. I've talked to the ISP several times, and they claim it can't have anything to do with the modem, and stick with the story that the problem isn't theirs. I've also asked the customer service reps. to try the websites in question from their computers, and they are successful.

I'm absolutely certain that the problem is theirs, as she has no problem surfing at coffee shops or anywhere else.

And yes, I've tried clearing the browser cache, DNS cache and changing the DNS servers to OpenDNS.

Any ideas on what might cause this experience?

Thanks!

share|improve this question

3 Answers 3

up vote 8 down vote accepted

I access the the internet from Germany and I also had the problem that certain sites were very slow and I got timeouts.

Affected sites were especially facebook.com, ebay.de, istockphoto.com. Other sites like google.com or spiegel.de (a German news site) worked OK.

For me the solution was to set the MTU properly. After I had done so on every machine in my home network, everything works fine. See also: How to change the MTU for troubleshooting purposes

To find the proper MTU use the following command:

ping -D -s 1472 www.google.com

If it gives you a "packet needs to be fragmented" or similar message, then reduce 1472 and try again. The highest value with no "packet fragmented" error plus 28 is your optimum MTU. For a more detailed explanation see also: Max MTU: How do I find mine?

share|improve this answer
    
You are golden! I changed it to the minimum, 72, and everything works great. –  Permetrin Aug 22 '09 at 15:00
    
I'm glad that it worked for you. Setting it too low will make the connection slower than necessary however. I've add some remarks about this to my answer. –  Ludwig Weinzierl Aug 22 '09 at 15:08
    
Thanks, Ludwig! I set it to 638, which seem to be an ideal value. –  Permetrin Aug 22 '09 at 15:27
    
+1 Very good and detailed answer. Definitly usefull for me as well. –  Diago Aug 22 '09 at 15:47
    
Did it really only affect HTTP POST's? It should have affected other things, like sending mail. –  benc Aug 23 '09 at 7:00

I think this is problem with connection to foreign countries.

Check where is a bottleneck for slow servers via traceroute (MAC OS X) or tracert (Windows) tool.

share|improve this answer

This appears to be a network problem beyond the ISP somewhere.
You should get some tests done with things like SpeedTest

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.