Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Do I have to download all other IEs since 6 to get the update 7 or higher that Yahoo is requested for their upgraded program? It looks like 8 is combined with 7 and you cannot download 7 natively, so then there is 9. Should I just download the 9?

share|improve this question
2  
What version of Windows are you using? Windows XP cannot run IE9, it will only work on Vista or Windows 7. –  Mokubai May 1 '11 at 19:17
1  
Stop using IE. - –  Hello71 May 1 '11 at 19:33

1 Answer 1

My advice is to stick with IE8. Wait a while to go with IE9 as not every application is compatible with it at this point in time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.