Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I open a folder in Windows Explorer, it opens the folder in a new window.

I double-checked all the options in Folder Options, including Launch folder windows in a separate process but changing that has no effect.

I can open the folder normally by right-clicking on it and selecting "Open". It works but obviously involves additional steps.

I've tried rebooting and have checked that my Ctrl key isn't stuck, but the problem still exists.

Any ideas? Are there any registry tweaks to fix my problem?

share|improve this question
2  
Have you tried restarting? I've had this randomly occur before, and a restart fixed it. –  nhinkle May 2 '11 at 7:56
    
yup, I tired it already. the problem is still remaining. –  Ye Lin Aung May 2 '11 at 7:57
    
I've had something similar too, I think if the <Control> key is stuck down it does that as well... –  Mokubai May 2 '11 at 7:58
    
my <Ctrl> key works well. –  Ye Lin Aung May 2 '11 at 7:59
1  
When you right-click a folder, is the default (bolded) action "Open in new window" instead of "Open"? –  Justin May 2 '11 at 13:28
add comment

3 Answers

This tip should do the trick.

share|improve this answer
    
This link is broken - can you provide another or a cached copy? –  amccormack Sep 22 '11 at 19:02
    
Works fine for me. Here is the text: Resolution Open Control Panel, double-click Folder Options and select the General tab. Select the Open each folder in the same window option and click OK. If that does not correct the problem, then this may be due to incorrect settings in the registry. This can easily be fixed using the REG file below. Download samefolderwindow.reg below (for Windows XP only) and save to Desktop. Right-click the file and then choose Merge. –  Justin Oct 12 '11 at 17:34
    
I can read it now as well. In any case the question states that the folder option solution was already tried. Furthermore the question is tagged as Win-7 not Windows XP. –  amccormack Oct 13 '11 at 18:09
add comment

I had the same problem. To fix this issue, follow the steps given by Justin except if 'open in same window' is already selected, select 'open in new window'. Click Ok. Open the same Folder settings window and select 'open in same window' and click Ok. That should fix the issue.

share|improve this answer
add comment

A web page describing the solution to this problem used to exist, but you can still find it on archive.org.

I’m not sure of the exact details, but this is what I think I’ve found. Perhaps someone at Microsoft would correct or elaborate on this. Previously, actxprxy.dll (ActiveX Interface Marshaling Library) was used as the proxy for a multitude of system interfaces, such as IShellFolder and IServiceProvider. In Windows 7 (and probably Vista also), the GUID of this library has changed from {B8DA6310-E19B-11D0-933C-00A0C90DCAA9} to {C90250F3-4D7D-4991-9B69-A5C5BC1C2AE6}. Secondly, there is also a new Proxy/Stub provider found in ieproxy.dll of Internet Explorer (IE ActiveX Interface Marshaling Library). Some interfaces that previously used actxprxy.dll are now registered to use ieproxy.dll. Now various problematic software (such as Vault 3.x) will try to register against actxproxy using the old GUID, and for interfaces now proxied by ieproxy.dll.

To solve, re-register 2 DLLs and reboot:

regsvr32 "%SystemRoot%\System32\actxprxy.dll"
regsvr32 "%ProgramFiles%\Internet Explorer\ieproxy.dll"

HTH

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.