Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i have long used emacs, and have even long used emacs.app .

recently, i upgraded to 23.3, and i discovered that a couple of default behaviors changed. one in particular that annoys me now is that when i perform "Open with" to emacs (whether this is from another app that does this or from finder using the context menu), it no longer opens the file in the original frame, as i prefer, but in a new frame, which i find extremely annoying.

i have searched high-and-low for an appropriate variable to set in order to restore the original behavior, but i have not found it and i am not certain what it would be named. (i presume something with the word "frame" in the title, but a C-h a frame turns up a lot of alternatives, and C-h v TAB and search through the list of variables for the text "frame" also is highly ambiguous.

i would greatly appreciate help in customizing my emacs back to the way it was a week ago.

share|improve this question

2 Answers 2

It's hard to imagine the developers changing this behavior changing so radically in a patch. Try checking the NEWS file (Ctrlh-n) for a change to that effect.

I suspect something you're loading has changed its behavior. Close all emacs sessions and start a new one disabling all extensions:

$ emacs -q --no-site-file

then try it again. If it works as expected you have an afternoon of hunting ahead of you to try to figure out which extension is causing the undesired behavior.

Finally, emacsclient (which I assume is what's used by your environment) will by default not open in a new frame. Try it manually from a terminal window:

$ emacsclient .bashrc

and see how that behaves. Maybe there's an alias or something that's forcing it to use a -c option? If you're on Windows you may need to hack the registry to see how emacsclient is being invoked.

share|improve this answer

Struggled for a while to find the answer to this and eventually did

(setq ns-pop-up-frames nil)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.