Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i am a web developer and have exim4 installed on my dev box, recently i needed to send a scripted email to a few project managers and so got exim heavy and all that setup which went well. Now i'm back to developing system emails locally (password reset etc) i'd like to switch exim to deny all remote email addresses as i don't want any chance of email leaving my development environment, reconfiguring exim seems like the wrong way to go about it.

Is there a config setting for this or a hack to make all remote mail fail? googling has left me puzzled.

share|improve this question
    
I see you rollbacked my edit regarding the disable tag cleanup. Please go here for information on this cleanup –  ṧнʊß Jul 15 at 14:03

1 Answer 1

up vote 1 down vote accepted

Disable all "routers" that deal with outgoing mail – domain_literal, dnslookup by default, but there might be others. Look at the transport field of every router.

(Note: I cannot answer any questions about the multi-file macro-generated configuration mess such as the one found in Debian. I'm sticking with a small exim.conf myself.)

share|improve this answer
    
do you know how i can tell which router is being used, setting domain_literal, domain_literal_relay and dnslookup to LOCAL_DELIVERY has no effect, must be using another if LOCAL_DELIVERY value is right? –  Question Mark May 4 '11 at 14:26
1  
@Question: sudo exim -bt (with optional -d) and enter a local user name (such as "root"), it will tell you the router chosen and transport used. (Regarding "LOCAL_DELIVERY value", I will repeat that I cannot answer any questions about configs generated from macro templates. I don't understand that stuff myself.) –  grawity May 4 '11 at 20:50
    
brilliant sudo exim -v -d -bt remote@example.com gave me more than enough info cheers, spoiling the transport (remote_smtp_junk) in dnslookup did the trick –  Question Mark May 5 '11 at 12:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.