Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Samsung SpinPoint P120 SP2514N 250GB hard drive that Windows 7 reports to be a 31.5GB disk.

The drive is definitely a 250GB disk - this is not a case of mislabelling. If I go into disk management the 'Extend Volume' option is greyed out. I've installed 'Acronis Alignment Tool - Samsung Edition' but it does not let me select the drive.

How can I restore the correct capacity of the drive?

enter image description here

share|improve this question
    
Is there only a single partition on the disk? –  Shinrai May 2 '11 at 15:27
    
It's probably your BIOS reporting the size incorrectly. –  user3463 May 2 '11 at 15:28
    
Does the Windows Disk Manager (Start -> "mmc diskmgmt.msc" [enter]) show empty space after 35.1GB (as in maybe the partition was truncated for some reason)? –  ultrasawblade May 2 '11 at 15:52
    
@ultrasawblade Not entirely sure what you are asking. Does the above image answer your question? –  Dan May 2 '11 at 16:22
    
This is probably an issue with your bios (since windows will just use what the bios detects). You may need to check with your computer manufacturer (or motherboard manufacturer) to see if they support drives of this size or if so do you have the latest bios version. Since you are running Windows 7, I would expect the machine to be newish and hence the bios to be newish and support such drives. It is also possible that some option on the bios is set wrong (eg LBA mode off etc). –  sgmoore May 2 '11 at 16:48
show 1 more comment

1 Answer

Try out HDD Capacity Restore Tool it might help... if not check the jumpers on the HDD and reset the BIOS settings to default.

HDDrestore

share|improve this answer
2  
There is an option on most drives to limit the capacity to 32GB by shorting two pins with a jumper. As this person says, check your jumpers; this could be the issue. –  Sean C. May 2 '11 at 17:15
    
You can also enable this setting in BIOS. Check there too. –  surfasb Jul 1 '11 at 1:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.