Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently used bcdedit from an elevated command prompt to turn 'testsigning' on so I could load a custom driver. Much to my dismay, when I rebooted nearly all of my drivers were ignored by windows, including my internet adapter and usb ports.

I figured the obvious solution was to just turn 'testsigning' back off. Unfortunately both this and a system restore had zero effect . This is the command I initialy used:

bcdedit /set TESTSIGNING ON

The system is a Dell Inspiron laptop with Windows 7 Professional 64-bit.

I have a Linux partition which, as always, loads up without complaint so at least I can get to Google but so far I haven't found any useful information.

Anyone know what might have gone wrong?

share|improve this question

migrated from stackoverflow.com May 2 '11 at 22:10

This question came from our site for professional and enthusiast programmers.

    
I have bcedit not installed but in the docs it is / and not - for the command line switch. But in any case you must Authenticode sign your driver or it won´t load. More info can be found here sysprogs.org/signing –  Alois Kraus May 2 '11 at 19:10
    
Thanks for the reply and the link Alois. The problem I'm having is that even most of the drivers from Dell aren't working and I know those are signed properly. –  Ctesibius May 2 '11 at 19:37
    
Does your computer have access to the internet? Windows does update its CRL (Certificate Revocation List from time to time). If it cant it could be that certain certificates are considered unsafe. –  Alois Kraus May 2 '11 at 20:45
add comment

1 Answer 1

up vote 1 down vote accepted

Look in Device Manager for the flagged devices (error code 39 probably).

Go to Start > Run > type regedit then browse to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class

Use the key to browse through the subfolders looking for the devices that don't work.

When you find one look for the value Upper Limit. Write down the value and delete it. Find the same device in Device Manager and disable then re-enable it.

If this works, repeat with all devices not responding.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.