Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am attempting to setup remote-desktop such that I can connect to my home PC using Windows Remote Desktop software. I have the following setup:

Cable Modem (Motorola SB 5101).
Cable Modem connects into Vonage Device (Motorola VT2142-VD)
Vonage Device connects into D-Link wireless router (DLink DIR-615 rev C)
Home-PC connects into D-Link router via Ethernet cable

I followed the instruction on portforward.com for both devices but it doesn't seem like it's working. I've scoured the internet and haven't found anything that might solve what I'm attempting to do. I have setup a "free" ddns system via the dlinkddns.com extension, and can now

Last note: I have Windows 7 (Ultimate) running on Home PC running on 192.168.0.100 (static assignment). I have enabled RDP in the System Settings, what I'm having difficulty is connecting to the RDP when I use the ddns.com service. Any help/direction would greatly be appreciated!

share|improve this question
    
What I would recommend is to flash your DIR-615 with DD-WRT which has VPN option. Set that up, you can find tutorials on DD-WRT webpage. Once you VPN you then can safely (safer than just RDP) connect to your machine. –  Darius May 3 '11 at 3:01
    
What happens if you put actual IP address into RDP? –  Darius May 3 '11 at 3:02
    
Using another computer in the LAN, I've verified that the RDP successfully connects to my machine with the login credentials I provide. Thusly, when I type in 192.168.0.100 from the non-host machine (both connected to LAN), I get RDP working properly. –  Magnum May 3 '11 at 5:06

2 Answers 2

up vote 1 down vote accepted

First test RDP locally to make sure it works. If you can't from one computer to another on your LAN, it isn't going to work over the internet. Once you know it works, you can verify your port forward settings. This can be difficult depending on the hardware you must traverse and what is setup for NAT. Is your cable modem bridged or is there NAT? If it has NAT enabled, do you have access and if so, have you verified you are forwarding on the correct port from the WAN of the modem to the LAN IP that you are using for the WAN of the Vonage device. Same concept with the Vonage device. Basically everything that has NAT has to point to the WAN of the next device. Without knowing exactly how your addressing looks, here is a possible setup:

Cable Modem WAN IP xxx.xxx.xxx.xxx Port forward on NAT from xxx.xxx.xxx.xxx:3389 to 192.168.0.33:3389 (LAN IP of Modem is 192.168.0.1)

Vonage Device WAN IP 192.168.0.1 Port forward on NAT from 192.168.0.33:3389 to 192.168.1.47:3389 (LAN IP of Vonage device is 192.168.1.1)

DLink Router Port forward on NAT from 192.168.1.47:3389 to 192.168.2.2:3389 (LAN IP of router is 192.168.2.1)

Computer RDP running on port 3389 with host address of 192.168.2.2

share|improve this answer
    
Sorry I can't upvote your answer. In any regards, you've pointed me in the right direction. I am attempting to figure out how to port-forward from my surfboard 5101 to my Vonage device... but I think that's the only hold up now. –  Magnum May 3 '11 at 6:08

If you are having trouble with RDP, place your PC in the Modem or Router's DMZ and see if you can connect. This was a nasty problem for RDP and RWW users of SBS 2003. For diagnostics, you can use a port scanner: http://www.whatsmyip.org/port-scanner/ to help.

For full SBS 2003 all these ports needed to be open. Try opening them all to make sure your Modem / Router is actually mapping the ports properly as not all do.

SMTP  25
HTTP  80
SSL   443
HTTP2 444
PPTP  1723
RDP   3389 
RWW   4125

If you are successful then close the ports you do not need.

You will find more help if you search for RDP and RWW for Small Business Server (SBS 2003, 2008, 2011).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.