Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This morning I noticed the text in Gmail (in Firefox 4) looked a little funny (kind of thin, maybe some color fringing). I went to work and thought it might be some ClearType issue or something with the way Direct way that FF4 draws to the screen. When I came back from work (I left the computer on), the problem was much worse - way beyond ClearType nit-picking. The text was barely readable.

I opened Chrome and there was no such problem. It seems like only Windows that use hardware acceleration are garbled, and ones that use GDI are not. But, I fired up Dragon Age and didn't notice any problems (I only really looked at the main menu though).

Here is a link to a screen shot that illustrates the problem. Notice how the Windows Live Mesh window is completely unreadable, the text in Firefox 4 (left) is pretty bad, while Chrome, the Windows Control Panel, and the task bar are perfectly fine.

The fact that the problem shows up in screen shots and that it only happens in certain Windows makes me confident that the problem cannot be with the monitor or DVI cable.

I am using the AMD Radeon drivers from 4/27/11. The card I have (MSI Frozr II) came with a slight overclock (810Mhz) out of the box, but it looks like when I'm on the Windows desktop it's not running at full clock (CCC reports 450Mhz). Still, I underclocked it to the stock reference clock (800Mhz) and it made no difference. The idle temperature according to Afterburner is 42-44 Celsius, which seems a tad high but not enough to cause a problem - it's cold to the touch if I open up the machine.

What the heck could be causing this? The problem varies in intensity. As we speak I'm in Firefox and things look better than they did earlier - it'll probably get worse again soon.

Radeon 6950 (MSI Frozr II), Seasonic X 560, Core i5 2500K at stock clockspeeds, 16GB RAM, Asus P8P67 M Pro

share|improve this question

3 Answers 3

up vote 2 down vote accepted

From http://hardforum.com/showthread.php?p=1037183406 :

"Looks like you have Morphological AA enabled in the drivers. Firefox now hardware accelerates all 2D rendering so MLAA will blur the hell out of everything."

The screenshot there looks similar to part of your screenshot.

share|improve this answer
    
I had tried enabling Morphological filtering in order to solve the original weird-looking Firefox text problem. I disabled it after it didn't appear to work, but maybe it didn't take effect. I just restarted my computer after turning it off and the situation is improved (but I still have the slightly-crappy-looking Firefox text problem). I'll see how it goes. Still, I don't understand how the problem could have intensified over time if it was a driver setting. It seems like it would have been consistently blurry. I'll try to post an update after today. –  Greg May 3 '11 at 12:54
    
One more (unfortunate) thought - the fact that it shows up in screen shots may be enough to prove that Morphological filtering is not to blame, because Morphological filtering happens so late in the rendering that it does not show up in screen shots. –  Greg May 3 '11 at 13:47
    
I can report that disabling Morphological filtering (and restarting) seems to have contained the problem to within Firefox 4, and reduced the intensity of the problem to mere annoyingly-color-fringed-and-thin-looking-text rather than all-out blurriness. Reports that Morphological filtering doesn't show up in screen shots must be bogus. I still wish I could make Firefox look better, but it appears a lot of people have that complaint, and either Mozilla or ATI (or Microsoft's Direct Draw team) have to do something about it. –  Greg May 4 '11 at 13:22

I had the same issue and I noticed it the most in Live Messenger and Autocad. Disabling morphological filtering and restarting did the trick.

share|improve this answer

I had the same problem with blurry text in Firefox 4.0.1, Windows 7 64-bit, and a Radeon HD 6670 with latest drivers: Catalyst 11.5, May 9, 2011. (I have no text problems at all with the latest Chrome or Internet Explorer 9.)

However the problem immediately disappeared when I went to Firefox's Tools menu --> Options --> Advanced tab --> General subtab, and unchecked "Use hardware acceleration when available."

(I didn't have to disable Firefox 4.0.1 hardware acceleration with my old NVIDIA GeForce 9800 GT, so that would strongly suggest that this is an AMD/ATI problem.)

I don't know how this will affect Firefox's speed, but at least I can properly read the text now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.