Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Archlinux and began trying systemd these days.

However, I found that systemd doesn't load my /etc/rc.local script.

As mentioned in the Wiki page, I did have run systemctl enable rc-local.service, but this didn't help.

The content of my /etc/rc.local file is:

echo -n 120 > /sys/devices/platform/i8042/serio1/speed
echo -n 250 > /sys/devices/platform/i8042/serio1/sensitivity
iptables --table nat -A POSTROUTING -s 192.168.0.0/16 -j MASQUERADE

Any suggestions?

share|improve this question
add comment

5 Answers

up vote 9 down vote accepted

Arch might not have included the service unit file necessary to run rc.local.

Just create a file /etc/systemd/system/rc-local.service with the following contents (copied verbatim from my Fedora systemd system):

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.

[Unit]
Description=/etc/rc.local Compatibility
ConditionPathExists=/etc/rc.local

[Service]
Type=forking
ExecStart=/etc/rc.local start
TimeoutSec=0
StandardOutput=tty
RemainAfterExit=yes
SysVStartPriority=99

Then, just run systemctl enable rc-local.service as root to enable it. You can also test it/run it now by running systemctl start rc-local.service.

share|improve this answer
    
These two files already exists: /etc/systemd/system/multi-user.target.wants/rc-local.service and /lib/systemd/system/rc-local.service –  Felix Yan Jun 21 '11 at 4:09
    
It's probably disabled then. Try running systemctl enable rc-local.service. If you continue to have trouble, please post the output of systemctl status rc-local.service. –  Patches Jun 21 '11 at 4:31
    
You cannot issue "enable" on unit that has no Install section, this example will perhaps not work. –  lzap Aug 30 '13 at 12:28
add comment

With systemd 188-2, systemd complains about having no [Install] section and as such being unable to enable the rc.local service. Might have been the case with earlier versions but since Arch devs only recently announced systemd will become the default I am fixing up my system.

To fix that, just add a section for the multiuser target in /etc/systemd/system/rc-local.service:

[Unit]
Description=/etc/rc.local Compatibility
ConditionPathExists=/etc/rc.local

[Service]
Type=forking
ExecStart=/etc/rc.local start
TimeoutSec=0
StandardOutput=tty
RemainAfterExit=yes
SysVStartPriority=99

[Install]
WantedBy=multi-user.target

Create the /etc/rc.local script and make it executable with chmod +x /etc/rc.local

share|improve this answer
    
Nice catch. Given that I have an Arch build, this came in handy. –  mastashake57 Mar 29 '13 at 19:59
add comment

Don't forget to make rc.local executable - or the compatibility layer will not run it! In the above examples which are listed - you would run chmod a+x in order to make the rc.local file executable. As follows:

$ chmod a+X /etc/systemd/system/rc-local.service 

I would think another possible problem is the location of your rc.local script! If you haven't already added the compatibility to systemd (which should be built in - and seems to be by former mention of it already existing) you may need to double check your files location... On my OS I have rc-local at /etc/rc.d/rc.local so I ran the following:

$ sudo chmod a+x /etc/rc.d/rc.local
$ sudo systemctl restart rc-local.service
$ sudo systemctl status rc-local.service
rc-local.service - /etc/rc.d/rc.local Compatibility
      Loaded: loaded (/lib/systemd/system/rc-local.service; static)
      Active: active (exited) since Fri, 13 Apr 2012 14:42:39 -0600; 3s ago
     Process: 2285 ExecStart=/etc/rc.d/rc.local start (code=exited, status=0/SUCCESS)
      CGroup: name=systemd:/system/rc-local.service
share|improve this answer
1  
It is pointless to make the systemd service file executable, as shown in your first code snippet. Also, on Arch Linux, the file path is /etc/rc.local -- perhaps the contents of the systemd service file are incorrect. –  RavuAlHemio Feb 24 '13 at 21:13
add comment

Pkgfile (on my system) says:

$ pkgfile --search rc-local.service
community/initscripts-systemd

That package installs other stuff you may not want, but you can disable it. See also: https://wiki.archlinux.org/index.php/Systemd#The_initscripts-systemd_package

share|improve this answer
add comment

Two common gotchas:

  1. Don't forget to make /etc/rc.d/rc.local executable. You can use

    # chmod a+rx /etc/rc.d/rc.local
    

    to make it executable.

  2. Don't forget to put a #!/bin/sh line in the first line of /etc/rc.d/rc.local. Here's how things should look:

    #  head -1 /etc/rc.d/rc.local 
    #!/bin/sh
    # file /etc/rc.d/rc.local 
    /etc/rc.d/rc.local: POSIX shell script, ASCII text executable
    

    If you don't get similar output, edit /etc/rc.d/rc.local to add a line at the very top containing just #!/bin/sh.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.