Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a problem I was having that I "solved" with a righteous reformat. However, I have no idea what was causing it; hours of Googling led to perhaps one other person with a similar problem, and I frankly didn't know about Superuser at the time. My loss! Anyway, the problem is this:

After having Windows 7 Ultimate 64-bit installed for a few months, I started having issues with the Open/Save As commands from any given file menu. Any time one of those commands was chosen, the program in question would crash. (More specifically, the problem seemed to happen whenever an explorer window was opened to try to navigate files. E.g., trying to upload files to an email in Gmail would cause a crash as well.) I don't remember what program first crashed, but over time it happened on Word, Firefox, Chrome, IE, etc. Even Paint! Not Paint...

It started slowly, too: with each program, I realized I could always do one of the commands once before it would crash. That is, say for Word, I was able to Open once successfully, but further attempts would cause a crash. Same for Save As or any similar command. Then in Firefox or any other program, I could do each one only once, and so on.

There were never any popups or errors associated with this. I would simply press Open/Save As/whatever and for a split second I would see the explorer window come up, and then the whole thing would just close. The computer was, to the best of my knowledge, completely virus/malware/spyware/everything free.

I can't think of a major system event or change that precipitated this problem. I did make four minor (at least I thought) registry changes in order to make it so that "Favorites" and "Homegroup" would no longer appear in the navigation pane on explorer windows, including the Open/Save As windows (see instructions here and here, respectively. I followed the Step 9 instructions as well, as I do have 64-bit), but I made those months before I realized the problem was happening.

I'm open to the possibility that they were causing the problem the whole time, and that I was unobservant enough to have never realized it was going on until much later. If this is the case, I'm about to feel really foolish. Also worth noting, no one else on the forums I used in the first place complained about such a problem. Any thoughts on what happened from people far wiser than I?

share|improve this question
    
I would suspect the reg hacks, This problem has never happened for me on countless W7 installations of which I have never applied these hacks. –  Moab May 3 '11 at 13:13
    
@Moab: Yeah, I've not redone the hacks since reinstalling out of fear (man I dislike those nav pane options), and no problems have occurred. But it's kind of an "absence of evidence is not evidence of absence" issue, you know? Except we're not talking about nukes... And by the way, not sure if your handle is named for the city in Utah, but if it is, I love it there. There Moab Brewery is excellent. If it's not, ignore me! –  erekalper May 3 '11 at 13:19
    
@erekalper, yeah, I plan on going to Moab this month, do some biking and hiking. –  Moab May 3 '11 at 19:22
    
Made it back from Moab, it was great, did you ever solve this one? –  Moab Jun 17 '11 at 14:16
    
Did you check the usual suspects (Virus, spyware, trojans, etc)? Also, what reg hacks did you use? You mention nav pane options, that sounds suspiciously explorer related... –  Haqa Jun 29 '11 at 21:24

4 Answers 4

Sounds like a rogue Shell extension to me. Best that you rethink the applications you install, especially anything that add anything to Windows Explorer. This use to be common in 95/98. Basically a poorly written shell extension would poison/inject the process that calls the open/save dialog. The main process would slowly destablize.

Or of course, the registry edits. . .

share|improve this answer
    
Hadn't even though of Shell extensions... mainly because I try not to use them in general, for basically that reason. I think I'm going to try the reg hacks again on a different machine with nothing to lose just for testing. –  erekalper Jul 15 '11 at 12:21

For me it was due to having network visibility on. I tried creating a network with my girlfriend's Mac, and every time I opened the "Open" or "Save as" dialog, the program would crash. It turns out it crashes because it wants to load the network environment, and it couldn't because of some other error. I turned network visibility off and could load the "Save as" and "Open" dialogs again.

share|improve this answer

Thank you! I've had the exact same thing happening. Try to Save As from IE, Chrome, or FF and it crashes. Trying to save from Word, same thing. I updated the Network visibility and the problem vanished immediately. Here's what I did:

Open the Network and Sharing Center. On the left side click on Change advanced sharing settings. Click on Home or Work and then select T*urn off network discovery*. Save it and close. That's it.

share|improve this answer
    
So that worked for a bit, but it's not working anymore... –  Alan Mar 19 '13 at 19:03

I had the same problem on Windows 8. Although not because of changes in the registry. Instead I made a network connection to a shared folder on LAN at home. The problem occurred when I was connected to another network and the drive was therefore unavailable. Took a while before I found out that this was the problem though. I deleted the connection to the drive and replaced it by a shortcut on my desktop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.