Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to disable "Play user interface sound effects" and "Play feedback when volume is changed" in the Sound pref.pane via terminal/unix command/ARD on multiple computers.

fseventer shows /users/$user/preferences/com.apple.systemsound.plist being edited when I make changes to these properties in the GUI, but I don't see references for these settings in this .plist

Any help would be greatly appreciated!

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted

defaults is the command used to read/write preferences from the command line.

defaults write -g "com.apple.sound.beep.feedback" -int 0
defaults write "com.apple.systemsound" "com.apple.sound.uiaudio.enabled" -int 0
killall -HUP SystemUIServer
share|improve this answer
    
Thanks! This seems to work for the volume pops but it either isn't working for the general UI sounds or "Play user interface sound effects" doesn't do what I thought it does, which seems to be the cause because even when I disabled it via GUI it still exhibits the same behaviors I was trying to avoid. –  Ian May 3 '11 at 17:02
    
@Ian The general UI sounds (like dragging something to the trash or unmounting a volume) are in the SystemSounds folder, see my answer below. –  slhck May 3 '11 at 18:41
add comment

To disable all sounds, you could try:

sudo launchctl unload com.apple.audio.coreaudiod

share|improve this answer
add comment

I haven't tried this as I'm not on the Mac right now, but an alternative would be to move the System sounds where OS X won't find them.

/System/Library/Components/CoreAudio.component/Contents/Resources/SystemSounds
share|improve this answer
add comment

To silence UI sounds, enter this in Terminal:

defaults write com.apple.systemsound com.apple.sound.beep.volume -float 0

This will set the volume slider for UI sounds to it's lowest value. Test it by pressing an F key not assigned to Exposé/Spaces/Dashboard/...

share|improve this answer
1  
Fun fact: Set it to 0.5 and look at the slider position. It's just slightly above 25% -- it's not presented linearly to the user, probably to better approximate loudness perception. –  Daniel Beck May 3 '11 at 18:32
    
Oh, nice detail :) (I wonder what else they have in stock..) –  slhck May 3 '11 at 18:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.