Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For a long time, Gmail does not work correctly in Chrome on my machine. I am able to read/compose email without any problems, but the spinning wheel is shown forever. In Firefox 4, the same Gmail account loads very quickly and the Gmail favicon shows up quickly.

I also can't attach files in Gmail on Chrome - is this related?

My system is Windows 7 64-bit and I'm using Firefox 4 / Chrome 11.0.696. No antivirus software is installed.

share|improve this question
Same thing here actually on OS X with Chrome 12.0.742. Sometimes is finishes loading, sometimes it doesnt. Do you mean you can't attach it by drag & drop? – slhck May 3 '11 at 16:41
Have you ever tried uninstalling and reinstalling Chrome? I've found that fixes a number of issues, especially if you've gone through several automatic upgrades. – user3463 May 3 '11 at 17:47
@slhck, i can drag and drop, but the file selection dialog wont open. – Wei Shi May 3 '11 at 18:10
@Randolph yeah, re-installed several times. no go... – Wei Shi May 3 '11 at 18:11
Are you using any GMail tweaking extensions or greasemonkey scripts? – user May 3 '11 at 23:57
up vote 2 down vote accepted

This is most probably due to an extension that blocks either ads or Java or flash. Do you have flashblock or adblock installed?

I have clicktoplay enabled in chrome which results in the constant spinning wheel. If I select the option to Run all Plugins This time then the wheel disappears.

Try disabling all Chrome extensions and see if that works.

share|improve this answer
That's sneaky and makes me want to use gmail less, even though I've used it since I got my invite WAY back when. – Rob Sep 13 '11 at 16:14
I have no extensions on Chrome at all, but it goes one reloading forever. It's funny that works with IE8 and not Chrome. – Marco Demaio Oct 18 '12 at 11:35

Did you try testing it and opening it in a incognito window in chrome?

That should remove any remove any plugins or cache etc.

share|improve this answer
Doesn't work on incognito window. Happens on Windows 7 64bit and Linux Mint 64bit. Reinstalling browser on Win7 doesn't help. – Kamil Szot Mar 19 '13 at 14:10

Is your computer's date and time set correctly? I've found Chrome to be very sensitive to SSL certificate problems like expired and not-yet-valid certificates, and Gmail to just hang when there's an SSL failure.

share|improve this answer

You must log in to answer this question.

protected by Community Sep 13 '11 at 18:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .