Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just noticed today a weird problem related to Chrome, and it's present in both Mac Chrome and Windows (both XP and 7) as I've been able to see. Sometime this morning my extensions stopped displaying their normal pages and began simply showing a page full of chinese text.

I've attempted to uninstall/reinstall Chrome on two machines, but the problem is still present. I've also attempted removal of individual extensions (screenshot below, I've attempted removal and reinstallation of LastPass and Evernote) but to no avail. It displays both the popups from clicking the button, for all buttons, and on their options pages. It does not affect the default Chrome page.

Whatever this is it's travelling through the Chrome Sync; which is used on all but one machine (this one, as a safety backup) to sync data between them. Given the fact I now can't log in to my various extensions directly and it's spread to all my Chrome installations save one and I can't figure out where to remove it, this is rather a debilitating problem.

You can see what it looks like here.

My best guess right now is either some sort of bad extension (I installed Reader Plus this morning, before the problem, and have since uninstalled it but no change) or that reinstalling it would have done the trick, but there were some cached files somewhere causing the problems. I have run virus/malware scans and nothing has pinged them yet (although the full HDD scan is still running, it's passed Chrome's folders). So I'm out of ideas.

Addendum: Some more testing has shown this to be something in the preferences itself. Other synced areas (including extensions) are fine until preferences are synced, as soon as they are, this change occurs.

I greatly appreciate any advice and ideas for how to solve this. Thank you!

share|improve this question
    
This looks awesome. –  Daniel Beck May 3 '11 at 17:09
    
I'm sure it does look interesting. Unfortunately, it's rather troublesome. –  MedTechDeveloper May 3 '11 at 17:44
    
It's not just CJK, but also some other unicode characters. –  Lri May 3 '11 at 17:49
    
Can't you just trash the prefs? Or are they so hard to set up again? –  Daniel Beck May 3 '11 at 17:50
add comment

1 Answer

up vote 1 down vote accepted

Click the wrench icon. Select Options (It'll be Preferences on your Mac). Click the Under the Hood tab and go to "Web Content". Should have the setting there to change it back to english.

share|improve this answer
1  
This led me to the right answer, thank you! It turns out that under the "Font" settings the encoding had been changed from standard Western to UFT-16LE and that was the problem. –  MedTechDeveloper May 3 '11 at 18:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.