Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a synergy.conf that I'm sure works well, because it worked with my ubuntu1 acting as a synergy server.

Now, I migrated my ubuntu1 to mandriva. I'm trying to use mandriva as server, and another ubuntu2 as client.

Using the default configuration, and checked that my mandriva's hostname is OK, I started the synergys on mandriva, and the synergyc on ubuntu2, like I used to do with my old configuration.

Addendum: I disabled the mandriva default firewall. And synergy has the same version on both systems, that is 1.3.4, with protocol 1.3

What's happening: The server starts, but when I try to cross the mouse to the client, the mouse go back to my config. I'm sure this is not an error on the synergy.conf I'm using, because it formely worked.

I tried to use the option -f trying to see where is the error, but I didn't see nothing usefull. This is what I see:

server (synergys):

    2011-05-03T20:06:39 INFO: switch from "ciberglo-notebook" to "nsi-L1BVZP5" at 542,799
    CServer.cpp,460
2011-05-03T20:06:39 INFO: leaving screen
    CScreen.cpp,116
2011-05-03T20:06:39 DEBUG: open clipboard 0
    CXWindowsClipboard.cpp,313
2011-05-03T20:06:39 DEBUG: close clipboard 0
    CXWindowsClipboard.cpp,348
2011-05-03T20:06:39 DEBUG: ignored screen "ciberglo-notebook" update of clipboard 0 (unchanged)
    CServer.cpp,1479
2011-05-03T20:06:39 INFO: switch from "nsi-L1BVZP5" to "ciberglo-notebook" at 444,251
    CServer.cpp,460
2011-05-03T20:06:39 INFO: entering screen
    CScreen.cpp,98
2011-05-03T20:06:40 INFO: switch from "ciberglo-notebook" to "nsi-L1BVZP5" at 634,799
    CServer.cpp,460
2011-05-03T20:06:40 INFO: leaving screen
    CScreen.cpp,116
2011-05-03T20:06:40 DEBUG: open clipboard 0
    CXWindowsClipboard.cpp,313
2011-05-03T20:06:40 DEBUG: close clipboard 0
    CXWindowsClipboard.cpp,348
2011-05-03T20:06:40 DEBUG: ignored screen "ciberglo-notebook" update of clipboard 0 (unchanged)
    CServer.cpp,1479
2011-05-03T20:06:40 INFO: switch from "nsi-L1BVZP5" to "ciberglo-notebook" at 632,239
    CServer.cpp,460
2011-05-03T20:06:40 INFO: entering screen
    CScreen.cpp,98
2011-05-03T20:06:40 INFO: switch from "ciberglo-notebook" to "nsi-L1BVZP5" at 625,799
    CServer.cpp,460
2011-05-03T20:06:40 INFO: leaving screen
    CScreen.cpp,116

client (synergyc):

INFO: CScreen.cpp,98: entering screen
INFO: CScreen.cpp,116: leaving screen
DEBUG: CXWindowsClipboard.cpp,313: open clipboard 1
DEBUG: CXWindowsClipboard.cpp,348: close clipboard 1
INFO: CScreen.cpp,98: entering screen
INFO: CScreen.cpp,116: leaving screen
DEBUG: CXWindowsClipboard.cpp,313: open clipboard 1
DEBUG: CXWindowsClipboard.cpp,348: close clipboard 1

The config I'm using is:

section: screens
    ciberglo-notebook:
    nsi-L1BVZP5:
end

section: aliases
    ciberglo-notebook:
        10.12.4.173
    nsi-L1BVZP5:
        10.12.3.218
end

section: links
    ciberglo-notebook:
        up = nsi-L1BVZP5
    nsi-L1BVZP5:
        down = ciberglo-notebook
end

Also, to be pretty sure, I used the synergy-foss web_site (synergy+, plus), version 1.3.6, on both computers. And still nothing.

Any help?

share|improve this question
    
What's the problem? I don't understand what you mean by "when I try to cross the mouse to the client, the mouse go back to my config" –  Malvineous May 4 '11 at 0:40
    
@Malvineous My mouse is on the server, ok? So, when I go up, trying to cross the mouse to the machine nsi-L1BVZP5 (ubuntu2), instead of the mouse appear on that screen, it returns to my server's screen. –  Gabriel L. Oliveira May 4 '11 at 11:58
    
What do you mean by "returns to my server's screen"? If a client is not connected, the cursor will never leave the screen at all (so it can't "return"), so as you move up you will see it stay at the top of the screen, perhaps moving left or right a little (just as if you weren't running Synergy at all.) Alternatively if you move the cursor up and it jumps back to the middle of the screen, then everything is working correctly (the cursor has moved to the client), except that the cursor is meant to be hidden on the server while it is in the middle of the screen (so you can just ignore it.) –  Malvineous May 6 '11 at 0:06

2 Answers 2

It wasn't clear to me if you've done this: Be absolutely sure you've updated the config on Ubuntu2 to reflect that it is connecting to a new server.

You no doubt had to build a config for the new synergy server, but that's not enough. The client has to know about it as well.

share|improve this answer
    
I don't have a config file on my ubuntu2, since it's just a client. What I do there is just point to the IP of my synergy server. So, I don't get what you mean about sinalyze my client about my server. I thought that just doing synergyc ip_of_my_server was enough. –  Gabriel L. Oliveira May 4 '11 at 11:59
    
Fair enough. Are you absolutely positive you haven't mixed up rights and lefts for screen transitions on the server config? –  Chris_K May 4 '11 at 13:06
    
Yeah. I double checked it, thinking the same thing. But it's correct. Any idea? (I thought it was different versions, but i've installed the same version, and still nothing.) –  Gabriel L. Oliveira May 4 '11 at 13:08
up vote 0 down vote accepted

Talking to synergy mail-list, I found that this is actually a bug on synergy when server is a Mandriva system, and client is a Ubuntu system.

Trying to make ubuntu as server and mandriva as client, worked.

I changed my system operation to Linux Mint (instead of Mandriva), and now everything works like expected again.

Will finalize this question, but more help about this issue can be found on synergy mail-list.

Hope anyone have this problem.

Thank you all who tried to help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.