Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

But I have a Belkin Bluetooth dongle, the one that's listed on the Apple website. It worked right out the box on my SL 10.6.7 and my magic mouse connected great.

The only problem is when going to Mouse preferences, it immediately crashes the System Preferences.

Can anyone help me here?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

you're probably on an AMD based hackintosh booting with the -force64 flag, am I right? This means you're running the 64bit version of system preferences. The 'magic mouse prefpane' loads instructional videos by using quicktime, in this case the 64bit quicktime, which you can't use since AMD processors don't support the SSSE3 instructions (SSSE3 yes, not SSE3, big difference ;-) ). To avoid the crashing, load the 32bit version of system preferences by selecting the open in 32bit mode checkbox in the get info dialog.

Hope this helps.

share|improve this answer
    
Wish you were right but I'm not loading the -force64 flag, its booting with arch=i386 busratio=18 –  Sandeep Bansal May 27 '11 at 16:02
    
Hmm, in that case I wouldn't know how to fix the crashing. Maybe you can configure your mouse another way? For example by using magic prefs (magicprefs.com) or more 'hardcore' by editing preference files? (an educated guess points at /Users/<username>/Library/Preferences/com.apple.driver.AppleBluetoothMultitouch.‌​mouse for the magic mouse). –  user83233 May 31 '11 at 12:42
    
Or my second option, go back to a PS/2 Mouse and sell the not so ergonomic magic mouse :) Thanks anyway –  Sandeep Bansal May 31 '11 at 20:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.