Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a web server thats hosting a couple of websites on it.

On my home network and on my 3G iPhone the websites load really quickly, even after the cache has been cleared.

But when I get to University (and some of my users have been experiencing this problem) - the webserver is unreachable, often times out, slow to respond - and (if lucky) when it does send the initial HTTP headers it can take up to 30-60s to send the webpage's data.

While I'm at university, however, I can access cPanel (Port :2082), WHM and SSH. Although these services are often very very slow, and sometimes unreachable.

It's hard to fix this problem because the site works fine at home.

The server load/memory hovers around 1.2/15% respectively on average. Which I believe is pretty average.

Have you ever experienced such an issue? Thanks.

Answering Comments:

I can Ping the Webserver with Similar MilliSecond Response to my home network.

When i TraceRoute, I get to my Universities Gateway and then from there the hops time out until HOP 15-20 (but this is consistent with other websites such as google).

The Webserver is located in a Datacenter in the US - 2GB Ram, 2.5Ghz Processor.

DNS has been set up properly, Ping/TraceRoute can resolve the IP quickly.>

Although The internet connection is slow here, no other website (that I access) seems to have much of a problem.

share|improve this question

First try:

  1. What is the pingtime from the university to your home network? If it's long then it may be network problem rather than server configuration problem
  2. Does connection from other places work? e.g. internet cafe? If so - then it is even more likely that the connection from university had a problem.
  3. Where is the webserver you mentioned? Is it in a data center or at your home? Has DNS service been setup properly?

Give us some more information to answer with =)

share|improve this answer

Path MTU black hole? Have you tried traceroute from your University? Do you see any packet loss when pinging the webserver from your University? Do you have any problems with any other sites from the University or is it just your webserver?

To test for a PMTUD black hole, trying pinging with the don't fragment bit set while varying the packet size to find a threshold above which you don't get a reply. Start with a payload size of 1472 and work your way down from there. Check your ping help/man pages, but here are some examples:


ping -s 1472 -M do destination


ping f -l 1472 destination

If none of that turns anything up, it's probably time to break out Wireshark.

share|improve this answer
Ping it with Bytes 1472 - Works Fine. – Moe May 4 '11 at 11:04
Pinged it with 65000 load. 100% Timed out. – Moe May 5 '11 at 1:10

I found the problem.

The firewall was blocking 99% of all inbound connections.

I had to turn off SYSFLOOD on the cPanel firewall and it fixed it.

Thanks for the responses.

share|improve this answer
were you the same person who originally asked the question? If yes, we can merge your 2 accounts – Sathya Jun 6 '12 at 6:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .