Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason, now I cannot connect to my SQL Server 2008 server remotely. I can login locally, but I get Error 1326 that I cannot connect to the server. SQL Browser is running, firewall ports were opened (I used the script given in Microsoft support link and verified on the server), TCP/IP, named pipes, and shared memory are enabled.

Any idea why I still cannot access it? I'm trying to connect from my laptop over a workstation.

Thanks.

share|improve this question

3 Answers 3

By default, SQL Server will only allow the local connections. You'll have to run the Surface Area Configurator tool to open it up to allow the remote connections as well.

[edited later]

I stand corrected. SAC is gone with SQl Server 2008.

Beginning in SQL Server 2008, the Surface Area Configuration tool has been removed. The features of the Surface Area Configuration tool that control SQL Server behavior have been replaced and greatly enhanced in the Policy-Based Management feature. [...]

The connectivity management features of the Surface Area Configuration tool are available by using the Configuration Manager tool. For more information about this tool, see SQL Server Configuration Manager.

More details at the SQL Server Configuration Manager page in MSDN.

share|improve this answer
    
OK, in 2008 R2 there isn't any surface area configuration tool... –  Brian Mains May 4 '11 at 13:20
    
OK thanks, I enabled remote connections. –  Brian Mains May 18 '11 at 19:43
    
Did that resolve the issue? –  Chris_K May 18 '11 at 19:48
    
No it didn't, strangely enough. It used to be the fix many a time, but this time it appears to be something else... but I can't figure out what: remote connections are on and 1433 is enabled... –  Brian Mains May 18 '11 at 20:13

Check the (Windows) firewall settings (and the SQL server settings) - by default windows does not allow SQL server to be remotely accessed.

share|improve this answer
    
1433 is enabled in windows firewall... –  Brian Mains May 18 '11 at 19:43

I had a similar problem, but I had to go into SQL Server Configuration Manager and start Sql Server Browser service. It was not running, and once I got that to run, I was able to connect over the network.

Also, enable TCP/IP protocol for SQL Server 2008 Express to accept remote connection under Network Protocol and Native Client settings in Configuration Manager.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.