Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to clear the cache for a specific domain name in Chrome. Is there an extension or other method that I can use to do this?

share|improve this question
    
The problem with this is that it is not as simple to clear the cache as you would think. When a browser caches files, it does so based on its URL. The complication is that many sites share common files like Google API scripts, Gravatar icons, etc. How would you go about clearing the cache for only a specific site? Should the common files it loads be deleted as well (and thus partially clearing the cache for other sites)? Or should they be left intact? (probably the most “correct” solution). –  Synetech Aug 7 '13 at 1:12
    
Honestly, none of these answers really "answer" the question for me. These are developer answers. The root question is how a regular person would do this. It would be unreasonable to ask a non-developer to do these things. –  Will Strohl Apr 21 at 14:46
add comment

4 Answers

up vote 50 down vote accepted

This may be a quicker/simpler way:

  • Press F12 to open Chrome Developer Tools (will pop up from bottom)
  • Click settings "gear" icon in top-right corner
  • Under General check Disable cache
  • Reload page and re-enable caching by un-checking this box
share|improve this answer
3  
Thanks, this actually works unlike the other answers which confuse cache and cookies ;-) –  Peter Jenkins Dec 3 '12 at 13:58
1  
But does it actually clear the cache for the page or just load it without using the cache? That is, if you open the cache directory, are any files related to that page gone after you reload? –  Synetech Aug 7 '13 at 1:10
    
That's a pretty manual way of doing it and can get annoying if you have to do it multiple times. Fortunately there's an easier and faster way: superuser.com/a/598260/83619 –  Tom Auger Jan 30 at 17:52
    
Currently Chrome Developer Tools seems to disable cache only while DevTools is open without actually clearing it. –  Jaak Kütt Feb 21 at 15:26
add comment

Here's how to delete Chrome's cookies selectively by domain or subdomain:

  • go to chrome://settings/cookies
  • select tab Details
  • type the domain name in the search box
  • click delete

More details here:

http://oxid-blog.euroblaze.de/miscellaneous/delete-google-chrome-cookies-selectively-by-domain/

This can't however select cookies by web folders, e.g. www.domain.com/folder1.

share|improve this answer
2  
Welcome to Super User! It would be nice to include the essential parts of the answer here, and provide the link only for future reference. –  slhck Jun 26 '11 at 13:11
15  
The question was about clearing the cache, but you answered how to clear cookies. –  Daniel Serodio Nov 28 '12 at 12:28
    
Found cache also from within the same details tab. –  Jaak Kütt Feb 21 at 15:25
add comment

After opening up the developer tools (usually by pressing F12) Click + Hold on the "Reload Page" button. From the popup list, choose "Empty Cache and Hard Reload".

Not sure this clears the cache for the entire domain. But probably satisfies 90% of the use cases of people that visit this SE question.

Note: In some cases this will NOT open the popup list. This is because the page isn't cached at that time, so the menu is not invoked.

share|improve this answer
1  
Doesn't seem to work on mac. –  pinouchon May 22 '13 at 7:27
2  
Try having the Developer Toolbar open first - hit F12 (or CMD+SHIFT+C for Console). I haven't tested on a Mac. –  Tom Auger May 22 '13 at 15:16
    
thanks @Hashbrown for the edit. I should have amended my answer. –  Tom Auger Aug 14 '13 at 18:59
    
no worries. this solution is just faster than the selected answer, and less drastic than just disabling the cache altogether. I feel this needs to be up the top, and the only way it'll get upvotes is if people test it and it works for them –  Hashbrown Aug 14 '13 at 23:21
    
Indeed, no cigar on a Mac for me neither. Bummer. –  Arjan Aug 15 '13 at 14:07
add comment
Wrench -> Preferences -> Under the Hood -> 
Use DNS pre-fetching to improve page load performance

Disable it - thus dumping the whole application cache - reload the affected page - and then re-enable. If this happens often or doesn't clear the issue, some cache upstream from chrome is the problem and you should probably leave chrome's disabled.

Selective invalidation of an application layer cache (which is done strictly for application speed) since chrome has "no business" taking over for the system is might be an answer to some issue, but it isn't a very good answer.

(Lest you get huffy about my "no business" statement, I use pre-fetching myself as I like the zippiness, proper or not)

share|improve this answer
1  
Despite your parenthetical objections and the correctness of your solution, I'm huffy anyway. –  Blomkvist May 4 '11 at 12:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.