Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

on some Windows 7 machine, notepad.exe can launch from desktop but lots of Windows 7 machine, no matter x86 or x64, it cannot start. no error no warning, just silently quit, like you never click on it before.

Is there any policy or system setting to block this?

I thought it is quite common to copy notepad.exe to anyplace and run it, lots of Windows installer sample do this.

share|improve this question
    
I've never experienced this behavior. Are you sure you're not doing something else wrong ? –  Heandel May 4 '11 at 7:29
    
Yes, we tried on several machine inside company. some machine can do the copy and run, some machine copy and run failed. so funny. –  welemon May 4 '11 at 7:50
    
I think it's much more likely that a "Windows installer" is actually creating a shortcut to notepad.exe on the desktop or in the Start menu, rather than actually copying the Notepad executable itself. I can't think of a good reason why copying the executable would somehow be better than creating a shortcut. How are you creating the desktop icon? –  boot13 May 4 '11 at 16:14
    
Did you try creating a shortcut by right clicking anywhere on the Desktop, choosing create new item, new shortcut and pointing the source to C:\Windows\Systems32\notepad.exe with whatever name you wish? –  Darius May 4 '11 at 16:54
add comment

migrated from stackoverflow.com May 4 '11 at 13:28

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 4 down vote accepted

While you probably shouldn't copy the notepad.exe file around, when you do you need to also copy the mui files from xx-yy\notepad.exe.mui to the same relative location (where xx-yy is the language code such as en-US).

share|improve this answer
    
Great answer! I verified and it worked! –  welemon May 5 '11 at 10:28
add comment

Why are you copying the EXE directly? A shortcut to the original file is the best approach.

share|improve this answer
    
This is just a testing, the question itself maybe not useful, but it link to serious problem behind that. Can you explain why it cannot run? –  welemon May 4 '11 at 13:31
    
Most likely it's missing some dependencies or it's a permissions problem. –  mrnx May 4 '11 at 18:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.