Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded my Ubuntu desktop 10.10 to 11.04. I everything works fine except when trying to update the current R 2.12.1 to R 2.13.0.

I followed the readme:

http://cran.r-project.org/bin/Linux/Ubuntu/README

and added

deb http://cran.xl-mirror.nl/bin/Linux/Ubuntu natty/
deb-src http://cran.xl-mirror.nl/bin/Linux/Ubuntu natty/
deb http://nl.archive.Ubuntu.com/Ubuntu/ natty-backports restricted main multiverse universe

to my

/etc/apt/sources.list

and also added

The Ubuntu archives on CRAN are signed with the key of "Michael Rutter " with key ID E084DAB9. You can fetch this key with

  gpg --keyserver keyserver.Ubuntu.com --recv-key E084DAB9

and then feed it to apt-key with

   gpg -a --export E084DAB9 | sudo apt-key add -

Which appears in the synaptic package manager (so I assume it worked).

but when running sudo apt-get update I obtain an error saying that:

Reading package lists... Error!

E: Encountered a section with no Package: header E: Problem with MergeList /var/lib/apt/lists/cran.xl-mirror.nl_bin_linux_ubuntu_natty_en E: The package lists or status file could not be parsed or opened. E: _cache->open() failed, please report.

and

An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:Encountered a section with no Package: header, E:Problem with MergeList /> var/lib/apt/lists/cran.xl-mirror.nl_bin_linux_ubuntu_natty_en, E:The package lists or status file could not be parsed or opened.'

how can I solve this? I am not an experienced Ubuntu user but have been using R on Mac and Windows.

share|improve this question
up vote 5 down vote accepted

I suspect the CRAN mirrors do not yet have a line for 'natty'. Just make it

deb http://cran.xl-mirror.nl/bin/linux/ubuntu maverick/

for now and you should be fine. This would have been a good question for the r-sig-debian list which is for questions regarding R on Debian/Ubuntu.

share|improve this answer
    
No that is not working either - deb cran.xl-mirror.nl/bin/linux/ubuntu maverick/ - gives me the same error. – Janvb May 4 '11 at 16:23
1  
Did you try a different CRAN mirror? – Dirk Eddelbuettel May 4 '11 at 17:02
    
no. I tried the deb cran.xl-mirror.nl/bin/linux/ubuntu maverick/ which I am always using. I can try another one. – Janvb May 4 '11 at 20:37
    
solved - I ended up using a different mirror:deb cran-mirror.cs.uu.nl/bin/linux/ubuntu natty/ which worked. thanks. – Janvb May 5 '11 at 8:25
    
In which case maverick also worked? – Dirk Eddelbuettel May 5 '11 at 10:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .