Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When you hit alt tab on windows 7 and stop for a second on a window, it hides all other windows. Is there any way to tell Windows 7 to use the old classic behavior?

share|improve this question
    
+1, number one annoyance. – slhck May 4 '11 at 21:29
up vote 16 down vote accepted

The fade is controlled by a timer and the timeout can be adjusted to any time period you want. Therefore, by extending the timeout to a longer period of time, you can effectively disable the fade. To make the change requires an edit to the registry.

Open your Registry Editor (regedit) and create the following registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab

In that key, create the following DWORD value:

LivePreview_ms

and set the value to the desired delay (in milliseconds) of when you want the fade to begin. Setting to something like 10,000 (decimal) will prevent the fade for a full 10 seconds.

NOTE: You'll have to restart Explorer to see the results....the easiest way to do that is logout and back in again or to reboot your machine.

share|improve this answer
    
Killing explorer.exe from Task Manager and relaunching it from there (File > Run) also works. Thank you, that was so annoying. – SilverSideDown Nov 1 '13 at 13:46
1  
this didn't work for me, but like @limex's answer mentions: setting it to 0 disables the feature - this finally worked – BeyelerStudios Apr 1 at 15:35
    
On Windows 7, version 6.1 (Build 7601: Service Pack 1) I found that setting LivePreview_ms to 10000 had no effect, even after a restart, but setting it to 0 did, as suggested by @limex below – MarkD Apr 29 at 10:09

In Advanced System Settings (accessible from the System control panel), click the Advanced tab, then the settings button for Performance.

In the list of Visual Effects the following affects this behavior:

  • Enable Aero Peek

You will need to uncheck this, doing so will remove aero effects sadly enough, so it's either one.

share|improve this answer
1  
This is not true. It is possible to (effectively) disable just the alt-tab functionality without loosing the whole aero effect. Please read and vote up the post by @Tall Jeff, who has provided a better answer. – Connor W May 5 '11 at 21:23
    
Also, if you would rather Windows 7 used the old alt-tab functionality, see the top answer from here: superuser.com/questions/37067/… – Connor W May 5 '11 at 21:25

Funny that Johns URL (http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/0c35c951-35c2-4820-893f-731e70f27b63) mentions a different solution. In contrast to Tall Jeff who sets 10000 to LivePreview_ms, I set it to 0. And it worked. So, the complete solution was for me:

  • Open your Registry Editor (regedit) and create the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab
  • Create a DWord Value LivePreview_ms
  • Set ValueData 0.
  • Restart the Explorer Service or the Computer.
share|improve this answer

The feature is called "Aero Peek". I was able to disable with:

Control Panel\All Control Panel Items\System\Advanced system settings\Performance
- disable Aero Peek

ref: technet.

share|improve this answer

The solution to increase the timeout didn't work for me. It looks like the timeout maxes out at 3,000 milliseconds. See:

In another Super User post, someone suggested VistaSwitcher. I just downloaded and installed it; it works perfect for me, nicer than the old Alt+Tab functionality and with no timeout.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.