Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got Ubuntu 11.04, but I'm trying to go back to windows 7. I know this is supposed to be easy, but I've tried every method I can think to no avail. I've burned at least 6 Windows 7 disks that did not work, tried multiple ISO files (assuming that some were corrupt in some way) on both dvds and usb devices, and consistently get the same error. What happens is when I restart and boot from the usb/cd/dvd drive, windows begins to setup, but before it can start to install, I get an error saying that a cd/dvd/media driver is missing. It then gives me the option to insert a media that has the driver to install it. I read dozens of threads, and finally read from someone who had the same problem, and found that it wound up being because of his SATA drivers, but I have been unable to to navigate Ubuntu well enough to know if this is true, or where to get SATA drivers. Any ideas/fixes I should try?

edit: I am trying to replace Ubuntu, not dual boot both OS's together.

share|improve this question

migrated from May 5 '11 at 2:43

This question came from our site for Ubuntu users and developers.

Question makes no sense. You said you are trying to install Windows 7 and it complains about lack of a driver. This has nothing to do with Ubuntu. If this is a typo and you meant Ubuntu, then you need to give the EXACT error message and/or post a screen shot. – psusi May 4 '11 at 23:16
No, I meant Windows 7. I already downloaded the SATA driver that was recommended for my laptop and put it on a usb device. When the driver error came up again, I prompted usb device containing the driver for download. The other forum said I would have to uncheck a box that hides incompatible drivers, so I did. But the driver was not detected. I thought this would be an Ubuntu issue because that SATA driver was recommended for Windows 7 64bit, but I am running Ubuntu, so it naturally did not work. – Anonymous May 4 '11 at 23:28
I edited the title to make it match the question. I suggest you add some details of the hardware and the source of your Windows-7 installation media (or ISO files). – RedGrittyBrick May 5 '11 at 9:42
Consider posting the make and exact model of the PC. – Moab May 5 '11 at 15:27
HAHAHAHAHA WINDOWS failing, what a joke i never fails! LOLOLOL – alexhairyman May 18 '12 at 18:24

Your problem has nothing to do with Ubuntu. I had the same problem when installing windows 7 onto a SATA HDD with USB. Some possible solutions I have found includes

  • If you are installing with CD, burn ISO with the slowest speed
  • If you are installing with USB drive, when it asks for driver, click Cancel. Once you are at the welcome screen, insert the USB drive to a different USB port. Then click Install Now to install.

You may also first try installing the ISO you have on a virtual machine, just to make sure it is not corrupted.

share|improve this answer
agreed, ubuntu doesn't change crap in windows, it doesn't just modify registries, etc. – alexhairyman May 18 '12 at 18:25

If you are "going back to Windows-7" this implies that the computer was originally supplied with Windows-7. In that case you should ignore Ubuntu and use the Windows-7 installation CD/DVD or the Windows-7 recovery CD/DVD that was supplied with the computer. If you do not have such a CD/DVD you should ask the retailer for one or contact the computer manufacturer for support. The manuals supplied with the computer should explain how to reinstall Windows-7.

I thought this would be an Ubuntu issue because that SATA driver was recommended for Windows 7 64bit, but I am running Ubuntu, so it naturally did not work.

When you boot the Windows-7 installation CD/DVD you are not running Ubuntu. The presence of bootable Ubuntu files on your hard disk (HDD) has no relevance, because your computer boots from CD/DVD not from HDD.

share|improve this answer

You must log in to answer this question.