Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just got a new laptop that came pre-installed with Windows 7 Professional edition. One of the new features of Windows 7 is Libraries.

I'm familiar with how this works and am trying to create my own library called 'Work' to include all my work folders on my computer. However every time I create a new custom Library, after I rename it, it disappears from my Library menu. Each time I click Libraries in the Explorer, I keep seeing the same 4 default libraries, I.e. Documents, Pictures, Music, and Video. So when I try to create a new Library called 'Work' again, I get a pop up message "Do you want to rename New library to Work (2).Library-Microsoft?"

Which means that my original work library still exists but for some reason I can't see it. Can someone please help me figure out why this is happening?

share|improve this question
I just tried setting my folder options to Show all files and I see my libraries. Seems that any new library created by me is being Hidden even though I'm not setting this. – Sean May 5 '11 at 8:23

I've been having this problem myself but with my default and custom libraries. So I went into the 'organize' tab on the top left and selected the 'folders and search options'. On the new dialogue box I clicked on the 'view' tab then selected the 'show hidden files, folders, and drivers' option. The problem was solved! I hope this helps!

share|improve this answer
Thanks Priya. Yes, this works for me too, but it's more like a tweak or a makeshift arrangement. Because I've enabled the 'show hidden files, folders, and drivers' I'm now having to see all the hidden system files which make my folders look very cluttered. Wondering if we're missing some setting/option or if this is a genuine bug that Microsoft is aware/unaware of :) – Sean Jul 20 '11 at 7:58

Same issue here. I like the libraries, but why are the libraries I create hidden? Further, the "Show in Navigation Pane" doesn't seem to work... for the same reason, it's a hidden file.

Anyway, I found an imperfect solution. This is definitely an issue.

Just be aware that making any change to the library, like "Show in Navigation Pane" or adding a folder to the library seems to set the folder to Hidden.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .