Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7 Home Premium and am connecting to the Internet through Homeplug.

When I connect and enable the LAN the status shows that I'm connected (the IPv4 shows connected), but after like 20 seconds it changes to No Internet connection. Even when it says I'm connected I can't connect to the Internet. My browser (Firefox) shows Server Not Found.

When I run the troubleshooter it says "Windows can't communicate with the device or resource (primary DNS server)."

What could be the problem, and how do I fix it?

share|improve this question

2 Answers 2

The reset command is available in the IP context of the NetShell utility. Follow these steps to use the reset command to reset TCP/IP manually:

  1. Open a command prompt by clicking Start, typing cmd, pressing Ctrl + Shift + Enter, and clicking Yes on the UAC prompt
  2. Type the following command in: netsh int ip reset resetlog.txt
  3. Reboot the computer

I tried this on my computer and it seems to work OK for me.

share|improve this answer

Use the "problem solver" (n&s center -> nic: dblclick -> diagnose) to automatically scan for errors and fix the problem. Failing that, set the DNS server manually.

If your home-router fails to acquire a working DNS server from your ISP, try using a free service such as Opendns: 208.67.222.222, 208.67.220.220

dns

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.