Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there any chance to prevent MS Visio (preferably 2010) connectors from routing when a text block is placed on top of it? I want to achieve the effect as if the text block is on the upper layer, above the shapes and connectors, but that the layers are completely separate (not affecting each other's layout).

Is that possible?

share|improve this question

3 Answers 3

Sounds like you need to change connector re-routing. I think the option you want is "Never re-route".

Firstly (if you haven't already) you need the Developer tab. Go to File|Options|Customize Ribbon and turn on"Developer" in the list of tabs.

Now select the shape you want and in Developer|Behaviour go to the Placement tab and select 'Do not layout and route around' in the Placement behaviour drop down. That should do it.

enter image description here

share|improve this answer
1  
This link is dead (a nice example of why stackexchange sites discourage answers that don't actually answer the question, but just link to the answer) –  Abacus Apr 7 at 18:25

Layering and grouping never seemed to make a difference for me (it still rerouted the connectors anyway), but changing the routing behavior of the placed object did. For Visio 2010 and 2013, the Behavior dialog is unfortunately and unnecessarily hidden by default. You have to customize the ribbon (File/Options/Customize Ribbon or just right-click on the Ribbon/Customize Ribbon), click the check mark next to the Developer chunk in the right-most list to enable it, and choose okay. Then select the shape you want to layer before and behind, click Behavior on the ribbon (Developer/Shape Design/Behavior), and on Placement, choose Placement behavior = Do not lay out and route around.

share|improve this answer

Typically what I do is add meta information like that to its own layer and then group and lock the layer. At that point Visio just thinks its drawing on a blank canvas again and won't attempt to route the connectors anymore.

Cheers! ~Chris

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.