Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a PDF document which has shaded areas (code fragments, to be precise) and I am looking to print the document out with shading in tact. The shading is light grey (as used on www.stackoverflow.com).

I have set the document to print 2 pages to one sheet (as the document is in excess of 100 pages), and this works perfectly well; my problem, however, is that the shaded areas are not printing out and the blocks of sample code are now printing without any 'definition'/shading applied to them, so they now appear to blend in with the rest of the text.

Is there a way to get the shaded areas to print as they appear on screen?

FYI, I am using Adobe Acrobat 8 Professional.

Thank you.

EDIT: I have attached an screenshot of a sample page that I am attempting to print. The area within the red ellipse is the area that I wish to be able to print as seen on screen. However, whenever I print the document, the shaded areas are no longer shaded and there is no clear definition between the code samples and the remainder of the text. Please also note that I have attempted to print one full page at a time and there is no difference.

The shaded areas within the ellipse do not print with any shading.

share|improve this question
    
Is anybody able to help with this? I tried adding an image but was informed that I was unable to do so due to my reputation score; for what it is worth, I have a much higher rating on StackOverflow - I posted this question on SU.com as it was not relevant for SO. –  SnookerFan May 5 '11 at 22:07
    
can you provide a sample PDF somewhere to download and look at? Without seeing the PDF itself it is impossible to tell why your shaded areas are not printed... –  Kurt Pfeifle May 6 '11 at 9:40
    
@pipitas I have now added an image - I was unable to do so before as my reputation score was below 10. I hope this helps? –  SnookerFan May 6 '11 at 12:22
    
I upvoted your question to give you more karma so you can put in more markups to your questions. But didn't ask for a screenshot image, I asked for the PDF itself to download and look at.... –  Kurt Pfeifle May 9 '11 at 11:13

3 Answers 3

up vote 2 down vote accepted

My wild guess is that you have some weird setting activated in your print dialog that you should change....

  1. Click "Print".
  2. After the print dialog opens, first select your target printer.
  3. Now click the "Advanced" button (lower row, second from left).
  4. Play with all the "Output" settings: Color, Screening, Trapping, Transparency Flattener Presets, Color Management.
  5. Play with all the "PostScript Options" settings: UnderColor Removal, Black Generation, Halftones,...
  6. Play with all the "Color Management" settings.

In the same dialog, you can also enable the "Print as Image" function (to checkbox). Try it.

BTW, what kind of printer is it that you are trying to print this to? (If it is a non-PostScript device, then some of the above mentioned settings will be disabled/grayed-out...)

Update:

I only now noticed from your screenshot, that you're using Adobe Acrobat Professional. In this case you can enable a rather sophisticated output preview:

  1. Menu Advanced -> Print Production -> Output Preview...
  2. Look at all the possible settings.
  3. Pay special attention to the lower pane named "Separations" (if you click on 'Separations' in the "Preview" pane first...).
    • Enable a Simulation Profile that matches your printer.
    • In case you're a using CMYK-based profile, check if "Process Black" is enabled.
    • Scroll to one of your "problem" pages which does not print its gray output as you want.
    • Move the mouse over the gray area.
    • Now note how the color values in the Separation pane change when you move the mouse: Does it indicate "enough" in the Total Area Coverage value to make the printer mark the gray background on the paper? If not, click on "Ink Manager" to change settings for Type, Neutral Density and Trapping Sequence.
    • If it still does not work: enable the Object Inspector in the "Preview" pane.
    • The lower, larger preview pane may be empty at first.
    • Now click on one of your gray-background problem areas.
    • The lower pane now fills with a textual listing detailing all the color settings for that page object. Tell us what is written in there....
share|improve this answer
    
Thank you so much for your assistance. The following is listed: Process Plates, Process Cyan: 5%, Process Magenta: 4%, Process Yellow 4% and Process Black: 0%. Please note that all five options are 'ticked'. Does this help at all? –  SnookerFan May 9 '11 at 16:56
    
@Mick: well, these values do make it a very "light" gray. It is well possible that the printer cannot print such a light gray at all and therefore it appears as white. I did ask about your printer, but you didn't answer the question... –  Kurt Pfeifle May 9 '11 at 17:21
    
@Mick: since you have Acrobat Professional, you should be able to use the "Convert Colors" and "Ink Manager" tools from the 'Advanced -> Print Production -> '-menu to darken the gray shades a bit to make them visible with your printouts... –  Kurt Pfeifle May 9 '11 at 17:35
    
@Mick: it could also be, that your "background" isn't a background at all, but a semi-transparent overlaid area, which your print queue (with the printer driver you're using for it) can't handle... In this case, you should look to "flatten" the transparency (with the help of your Adobe Professional) before you print the PDF... –  Kurt Pfeifle May 9 '11 at 17:46
    
@piptas Thanks for the suggestions. I have flattened the transparent overlaid area and this unfortunately has not resolved the issue as the document is still printing in the same way. My printer is a HP Deskjet F380. As per a previous request made by you, you may download the file from: mediafire.com/?9sq7257bxd7hrup. Thank you once again for your suggestions. –  SnookerFan May 9 '11 at 18:39

I just ran into the same thing with my B/W Brother MFC - when you click the print icon on the PDF, you get the print menu with select printer, print range, etc. At the bottom just above "Printing Tips" is a check box for "Print color as black" - ensure this is unchecked or the color will be blacked out.

share|improve this answer

I had the same issue, here is what worked for me.

I clicked "Print" and then under the properties button, there is a label "Comments and Forms" drop down box. I selected document and markups and that should print the document with any markups added.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.