Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to be able to compare to large spreadsheets side by side...

Since you can not natively expand to all monitors I would like to have the two documents open in two instances. These files are links on Sharepoint.

share|improve this question
1  
I believe this has been this way for several versions. Why launch and second instance when there is no reason. MS provides a way to do - see below. Calling Excel stupid probably hurts its feelings. –  uSlackr May 5 '11 at 16:53
    
Alternative: Stretch the window manually, then use Excel's "Arrange All" feature, under the View tab. –  Iszi May 5 '11 at 16:54

4 Answers 4

up vote 5 down vote accepted

In my experience, if you open the second spreadsheet using File >> Open, it opens in the same program window.

If you open a second Excel instance from the Start menu or a desktop icon or such, then use File >> Open in that window, it opens in its own program window.

I agree that it's broken behavior and I know of no way to fix it except, perhaps, begging Microsoft to change it in some future release.

share|improve this answer

Seems to be the default behavior for me -- I get a seperate process, even. Try launching excel directly without opening a file to see if you get a seperate process/instance and open your file with OfficeButton->Open.

share|improve this answer
    
I'm opening files from Sharepoint, it makes using File --> Open less of an option. –  MVCylon May 6 '11 at 12:29

You can see the simple method at this link, or use this solution:

Go To Control Panel->Folder Options->File Types
Choose XLS (or whatever extension you need to work this way)
Go to Advanced

Uncheck "browse in same window" in advanced window.

Then highlight Open
Click the Edit Button

Make sure in the Action box it says &Open

Make sure in the application used to perform action it says:
"C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE" "%1"

Check the box next to use DDE

Remove anything that is in DDE Message box and DDE Application Not Running box.

Make sure the application box says: EXCEL

And in the Topic box it says: System

share|improve this answer
1  
This will not work in Windows 7. They have removed or modified the advanced file type editing. AFAIK –  MVCylon May 6 '11 at 12:26
    
Please remove the non Windows 7 instructions and I'll accept your answer. The first link you provided worked perfectly. –  MVCylon May 6 '11 at 12:28
    
@Doug, I think those other instructions would work fine for Windows 7 also, though I'd always go for the simple solution. In fact, before posting this I verified (and changed them a little) them in Windows 7 (as far as where the settings were, I didn't actually hit the OK buttons). –  Lance Roberts May 6 '11 at 15:58

I had the same problem with opening files in Sharepoint. The (crude) method I use is:

  1. Open the first document in the standard way, by clicking the link in Sharepoint.
  2. Click on the Sharepoint dropdown for the second document and select Send To -> Email A Link.
  3. Open a second instance of Excel and use this link in File -> Open.
  4. Repeat as necessary.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.