Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I’m new to installing applications via the “Terminal,” so excuse my absolute ignorance on the subject.

I want to install SoX (Sound eXchange), so I can do some ninja audio editing. First I installed git, then I installed SoX. I didn’t get any error messages and the installation has spawned a sox-folder in my Users/myName-folder.

However when I use the program by typing sox in the “Terminal,” nothing happens, all I get is “command not found.”

Does anybody know how to troubleshoot this?

share|improve this question

migrated from May 5 '11 at 16:49

This question came from our site for professional and enthusiast programmers.

"Terminal"? As in OS X? – Ignacio Vazquez-Abrams May 5 '11 at 14:04
Yep, running OSX. – timkl May 5 '11 at 17:00
up vote 4 down vote accepted

Probably better on superuser? Based on the and /Users I am guessing you are on Mac OS X?

If all you did was git clone it down, you have the source code to the application and not a binary.

You would need to cd sox-folder and then do the ./configure && make && make install dance. But as you say you are new to this, that might be a bit rough.

If you are on Mac OS X then something like Homebrew or MacPorts might help you here, as they both have packages/ports for SoX. If you are not on Mac OS X, most distribution of *nix will have a package available (i.e. yum install sox, apt-get install sox, etc…) but more information would be needed.

If you just want to run sox, go here and grab the precompiled Mac OS X Binary: To compile what you have you will need autoconf, automake, etc… Basically the entire autotools toolchain, and that is probably overkill assuming you just want to run the utility.

share|improve this answer
Thx for helping me out. There is no configure-file in the sox-folder, however there was a, bash spits out the following when I run it: ./ line 3: ACLOCAL_AMFLAGS: command not found ./ line 5: SUBDIRS: command not found ./ line 6: DIST_SUBDIRS: command not found RM: =: No such file or directory RM: rm: No such file or directory RM: -f: No such file or directory ./ line 12: dist_man_MANS: command not found ./ line 13: EXTRA_DIST: command not found ./ line 31: syntax error near unexpected token `|' etc. – timkl May 5 '11 at 16:59
since you have the raw src code to Sox, you are going to need the complete auto* toolchain, as well as all of the Dev Tools, gcc, etc.. Do you have Xcode installed? I am guessing you just want to use SOX and don't need the bleeding edge version. I'll update my answer with a link to what you probably need. – Doon May 5 '11 at 17:30
@timkl Just install Homebrew using the one-liner and run brew install sox afterwards. – Daniel Beck May 5 '11 at 18:03
@Daniel That did it! Thx a bunch :) – timkl May 5 '11 at 18:26
@timkl Since Doon suggested it anyway, you can accept his answer. – Daniel Beck May 5 '11 at 18:38

This article explains in detail to have SoX running in Ubuntu. It worked for me, so I think it should work for you too


Simplest way in ubuntu would be to run these two commands

sudo apt-get install libasound2-plugins libasound2-python libsox-fmt-all

sudo apt-get install sox

If you are in some other Linux, like CentOS or you need support for Vorbis and Ogg, you will have to compile from source, found by following the link above

share|improve this answer
Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Canadian Luke Oct 26 '12 at 23:01
Thanks.This one exactly explains stuff. But since you suggested, i'll add some more info. – Manu Oct 26 '12 at 23:04
Much better! Easier to up vote when the information is presented here as well. Main reason is to prevent link rot – Canadian Luke Oct 26 '12 at 23:15

Check if it's in the path

which sox

try launching it using the complete path. /usr/local/.../sox

check permissions to the sox binary.

share|improve this answer

Install the App

  1. Press Command+Space and type Terminal and press enter/return key.
  2. Run in Terminal app: ruby -e "$(curl -fsSL" < /dev/null 2> /dev/null and press enter/return key. Wait for the command to finish.
  3. Run: brew install sox


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.