Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Eclipse in Windows XP. One of my favorite shortcuts is CTRL+ALT+DOWN (or CTRL+ALT+UP) to duplicate a line.

I just found that on this machine (XP ThinkPad, with NVIDIA graphics driver), this is has the effect of fliping the screen upside down, which I will rarely use.

How can I disable this? Or, if that is difficult, is there a way to give Eclipse hotkeys precedence over any other hotkeys? I'm not sure if this is an OS 'feature' or a background utility, or a function of the graphics driver, but any suggestions that would help me track this down and eliminate it would be appreciated.

I've looked through the choices on the NVIDIA control panel, and I don't find any hotkey options.

share|improve this question
1  
Are you sure it's and OS shortcut? Could there be a utility running in the background to control orientation? –  Tog May 5 '11 at 19:32
    
@Tog - Good point. How would you investigate this? –  Eric Wilson May 5 '11 at 19:33
    
Have a look in the programs list for oem utilities, check the task manager, check the startup list using msconfig –  Tog May 5 '11 at 19:40
add comment

3 Answers

up vote 12 down vote accepted

I have not tested on AMD/ATI graphics, but I know for a fact that all Intel drivers do this and some Nvidia drivers.

Simply go in to the configuration tool of your driver and look under a section called hotkeys and disable it.

For Intel:

Screenshot from the Intel specific display driver

share|improve this answer
    
I feel like a dunce, but I can't find the configuration tool of my driver. Where do I look? –  Eric Wilson May 5 '11 at 19:55
    
Found it, but didn't find hotkeys, edited question. –  Eric Wilson May 5 '11 at 20:04
    
Glad you found it... I think that nvidia listens on the driver level, therefore you won't be able to get software to listen "higher" than that - all you can do is change your graphics profile or the hotkey to something else... possibly control+shift+alt+direction? –  William Hilsum May 5 '11 at 20:23
    
For those who can't find these settings - try following the route: Control Panel → Appearance and Personalization → Display → Screen Resolution → Advanced Settings → Graphics Driver –  lyuba May 20 '12 at 15:13
1  
I found the hotkey settings in the Context Menu of the Intel HD Graphics SysTray icon. Graphics Options > Hotkeys > Disable. –  Somantra Jul 27 '12 at 13:29
add comment

Looks like the answer is to right-click your desktop, select Graphics Options >>> Hot Keys >>> Disable.

disabling graphics hotkeys

Though see here, where someone describes doing this, having it work for a while, and then having an update borking it for them. Others have suggested in a worst-case like this to uninstall the configuration software installed with your driver but to keep the driver. I'm a little anxious that that's not an nVidia fix, though, since you have to use the above route to disable them in the first place, not some sort of control panel.

In any event, the Graphics Options route worked for me in a similar situation.

share|improve this answer
    
Graphics Properties and Graphics Options are not always available (I checked on four computers, with Windows XP 32-bit, Windows 7 Enterprise 32-bit, and two with Windows 7 Enterprise 64-bit. Only one, one of the two with Windows 7 Enterprise 64-bit, had these two options). (Are these added by the specific display driver?) –  Peter Mortensen Oct 30 '13 at 13:29
add comment

That is a function of the display driver, not the OS. You will need to check the settings in the Display Driver to see if it can be disabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.